Opened 3 years ago

Closed 3 years ago

#14697 closed Bug (invalid)

IE takes a long time to load SCAYT

Reported by: Ronan Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

While activating SCAYT on IE10, IE freezes for minutes before actually loading the corrector.

  1. Enable SCAYT on IE 10

Expected result

Actual result

Other details (browser, OS, CKEditor version, installed plugins)

I launched a profiler on IE and monitor that these methods are the one which are lagging : "bondingWidth, boundingTop, boundingLeft and boundingHeight" (each one take 6 seconds to execute). CKEditor is configured by default. All plugin are active.

Attachments (3)

2016-06-21_111738.png (52.9 KB) - added by Ronan 3 years ago.
IE profiler
average.png (75.7 KB) - added by Jakub Ś 3 years ago.
worst.png (68.4 KB) - added by Jakub Ś 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Ronan

Attachment: 2016-06-21_111738.png added

IE profiler

comment:1 Changed 3 years ago by Jakub Ś

Keywords: IE SCAYT removed
Resolution: invalid
Status: newclosed
Version: 4.5.10 (GitHub - master)

I can't confirm your findings. I have tried loading standalone CKEditor on IE10 on my test windows with only 2 GB of RAM assigned. The worst result was 1,95ms while the average was 0,95ms.

This was verified on two different computers so it is very possible that problem is on your side.

Please note that SCAYT makes external AJAX calls to server so please make sure you are not blocking them. You might also want check if some script from your application, CKEditor third-party plugin is not conflicting with SCAYT.

Please also note that SCAYT is not our product (thus I will close this ticket) and all issues related to it should be reported to SCAYT team - https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues. In this case however I would not report an issue just yet because it is very possible that there is some problem on your side.

Changed 3 years ago by Jakub Ś

Attachment: average.png added

Changed 3 years ago by Jakub Ś

Attachment: worst.png added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy