Opened 11 years ago

Closed 11 years ago

#1470 closed Bug (worksforme)

A <br> is inserted when saving or hittng ENTER in summary field

Reported by: Tom Lamano Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: WorksForMe Cc:

Description

If I make edits to a page using MediaWiki+FCKeditor, then type up an edit summary, then hit Enter to commit instead of clicking "Save page" with my mouse, it commits but also inserts a carriage return near where I was working on the article. It should do one or the other: either it should not commit when you hit enter, or it should commit without also inserting carriage returns.

Attachments (2)

fiddler_post.png (224.7 KB) - added by Doru Moisa 11 years ago.
capture of the actual data sent by POST after hitting ENTER in summary field
IE.png (138.4 KB) - added by Doru Moisa 11 years ago.
the summary text appers to be alright (no <br>'s) in the history diff view

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Tom Lamano

In the above report, I note that MediaWiki+FCKeditor inserts a carriage return when you save a page by hitting enter in the edit summary field. It's actually not related to hitting enter; it happens when you click the "save page" button as well.

MediaWiki+FCKeditor inserts an extra, unwanted carriage return wherever your cursor was, every time you save a page, unless your cursor was at the end of the page. It happens whether clicking the "Save page" button or hit enter in the edit summary field.

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Summary: In MediaWiki+FCKeditor, using Enter key to save a page inserts a carriage returnA <br> in inserted when saving or hittng ENTER in summary field
Version: SVN

Confirmed on IE and IE7. Works fine in FF2.

comment:3 Changed 11 years ago by Wojciech Olchawa

Summary: A <br> in inserted when saving or hittng ENTER in summary fieldA <br> is inserted when saving or hittng ENTER in summary field

Changed 11 years ago by Doru Moisa

Attachment: fiddler_post.png added

capture of the actual data sent by POST after hitting ENTER in summary field

Changed 11 years ago by Doru Moisa

Attachment: IE.png added

the summary text appers to be alright (no <br>'s) in the history diff view

comment:4 Changed 11 years ago by Doru Moisa

Cannot reproduce this, maybe it was fixed with other commits. I attached two screenshots ( http://dev.fckeditor.net/attachment/ticket/1470/fiddler_post.png and http://dev.fckeditor.net/attachment/ticket/1470/IE.png). As you can see there is are no <br> tags that are inserted.

I'm using IE version 6.0.2900.2180.xpsp_sp2_rtm.040803-2158, Mediawiki svn rev.32912 and FCKEditor svn rev.1850

comment:5 Changed 11 years ago by Tom Lamano

My original summary of the issue was a little iffy. Please read my first response, where I try to clarify. The <br>'s were not being inserted in the edit summary. They were being inserted in the article itself, wherever I had left my cursor, unless my cursor was at the end of the article.

comment:6 Changed 11 years ago by Wojciech Olchawa

Keywords: WorksForMe added; Confirmed IE removed
Resolution: worksforme
Status: newclosed

It seems to work in my test as well so I'm closing this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy