Opened 12 years ago

Closed 11 years ago

#1471 closed New Feature (fixed)

Add preferences setting for "Edit Wikitext by default", while still allowing access to FCKeditor

Reported by: Tom Lamano Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5.1
Keywords: Confirmed Cc:

Description

Currently, MediaWiki+FCKeditor uses FCKeditor by default, with a "Wikitext" button to allow editing MediaWiki code directly. FCKeditor occasionally breaks some HTML and Wikitext trying to parse it, sometimes losing data, and so it would be great if by default I could edit Wikitext but still use FCKeditor at the click of a button.

It is possible for an individual user to disable FCKeditor in his preferences, but it would be more convenient if a user could opt to default to Wikitext while still having quick and easy access to FCKeditor.

Change History (10)

comment:1 Changed 11 years ago by Wojciech Olchawa

Component: GeneralProject : MediaWiki+FCKeditor
Keywords: Pending added

Hi tomthehand.

Could you please provide more information about the requested feature?

Do you mean something like mediawiki with a function to activate/deactivate FCKeditor?

comment:2 Changed 11 years ago by moridin1138

I think he means a setting whereby when you are creating or editing an article, teh default would be that the 'wikitext' is already selected and youre editing using wikiext. However you can 'deselect' the default and see what would normally be the default editor.

I too would find this useful, as I want our users to become accustomed to wiki syntax, but also have a backup in place (deselecting 'wikitext').

comment:3 Changed 11 years ago by Tom Lamano

Hey! Sorry, I didn't see the first comment on this request. Yes, that's what I mean: I'd like to be able to default to editing bare MediaWiki code, but I'd still like to be able to switch to FCKeditor if I want.

Right now, when FCKeditor is enabled and you edit an article, you will always start out in FCKeditor and have to manually switch to editing the bare code. FCKeditor is very helpful, but a little buggy, and so I have to disable it somewhat often; if there were an option for bare MediaWiki code to pop up first I would rarely, if ever, have to disable FCKeditor.

comment:4 in reply to:  3 Changed 11 years ago by moridin1138

It seems like normally it's the 'Source' button. So basically we want that turned on by default whenever editing/creating a page.

I haven't seen anything that would allow us to do that by taking a quick peek at the code. However I am no php/js expert by any stretch. :(

Hopefully someone replies with a little more knowledge than myself. :)

comment:5 Changed 11 years ago by moridin1138

Oh, and it's worth mentioning that a quick search of the forums and wiki have turned up nothing...

comment:6 Changed 11 years ago by moridin1138

http://mediawiki.fckeditor.net/index.php/Talk:Main_Page#Making_Wikitext_load_first_.28sort_of.29

I can confirm this works. Not beautiful, and Id love an alternative, but hooray anyways!!!

comment:7 Changed 11 years ago by Tom Lamano

Thanks! That helps. However, that fix does not keep FCKeditor from parsing the text; it just automatically switches to WikiText after loading up.

A big part of my reason for wanting this feature is that occasionally FCKeditor is buggy, and I don't want it to try parsing the text, but I want something quicker, easier, and more convenient than having to disable FCKeditor every time I work on a page it can't handle.

comment:8 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added; Pending removed
Version: FCKeditor 2.5.1

comment:9 Changed 11 years ago by skorpio21

Hi Tomthehand,

I'm looking for the same issue that this ticket, because this setting would be perfect to my Mediawiki 1.12 server. I have some programmation knowledge, so may be together would get something. Any idea whereby to start?

Kind regards.

comment:10 Changed 11 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed. Please take a look at #2191 for more information.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy