Opened 12 years ago

Closed 11 years ago

#2191 closed New Feature (fixed)

A button to activate/deactivate

Reported by: Dieudonné Dard Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

It would be very useful to be able activate or deactivate this editor with the click of a button like with wikEd for example.

Attachments (1)

2191.patch (4.3 KB) - added by Artur Formella 11 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added
Version: SVN

This request is related to your other tickets that is #2190 and #2192. We could possibly achieve those two tickets by creating an activate/deactivate button (issue from this ticket). In:

#2190 - if we would deactivate FCKeditor extension a rich editor would than be activated so the signature button wouldn't be a problem

#2192 - every user could disable FCKeditor extension by the activate/deactivate button so it wouldn't be a problem for disabling for those who don't want to use it.

comment:2 in reply to:  1 Changed 11 years ago by Dieudonné Dard

Replying to w.olchawa:

#2192 - every user could disable FCKeditor extension by the activate/deactivate button so it wouldn't be a problem for disabling for those who don't want to use it.

Precision on the idea of ticket #2192 :

Since this extension is still in beta version, the idea is to allow the testing of it only by experienced users (volonteers). It would be very helpfull to be able to set it active by default, or not, when installing the extension.

Thanks to re-open ticket #2192

Some users are actually trying to overcome this obstacle via tricks :

Change Default to "Disable rich editor"?

disable for existing users

comment:3 Changed 11 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed in the latest release. Please test it and report any (new) issues you find.

It should be now possible to choose the way how FCKeditor is loaded via Preferences -> Misc:

  • Start with rich editor disabled
  • Open rich editor in a popup
  • Use toggle to switch between wikitext and rich editor (replace textarea with rich editor)
  • Remember last toggle state

Use:

$wgDefaultUserOptions['riched_use_toggle'] = 1;
$wgDefaultUserOptions['riched_start_disabled'] = 1;
$wgDefaultUserOptions['riched_use_popup'] = 1;
$wgDefaultUserOptions['riched_toggle_remember_state'] = 1;

to change the default toggle settings for all users.

comment:4 Changed 11 years ago by Wiktor Walc

Actually it's a duplicate of #1471.

...and another ticket about the same issue: #1676 marked as duplicate.

comment:5 Changed 11 years ago by Dieudonné Dard

Thanks a lot !

:)

comment:6 in reply to:  3 Changed 11 years ago by janwb

Replying to wwalc:

Fixed in the latest release. Please test it and report any (new) issues you find.

I have installed the latest version (extension + fckeditor). The source shows the new parameters, but no matter what I do, the rich text editor still remains the default. What should I check?

Regards, JW

comment:7 Changed 11 years ago by janwb

Resolution: fixed
Status: closedreopened

comment:8 Changed 11 years ago by Wiktor Walc

Keywords: Pending WorksForMe added; Confirmed removed

Clear browser's cache, make sure that you have uploaded the extension into correct directory/server.

comment:9 Changed 11 years ago by dmarkow

Same problem as janwb. I installed everything, but even with the wgDefaultUserOption settings enabled to disable the FCKeditor by default, it still only shows the FCKeditor with no option to switch to the normal Wiki edit box, unless I go to the user's Misc options tab and manually set these options. Using latest SVN of Mediawiki-FCKEditor and MediaWiki 1.13.2

comment:10 Changed 11 years ago by Artur Formella

You should change default settings before you click to edit page. MediaWiki copy all these settings to profile when you load extension first time.

comment:11 Changed 11 years ago by dmarkow

That's exactly what I did. Looking in the user_options column for each user, none of the "riched_*" option fields have been put in there, so I don't know why it's not using the default options I set.

comment:12 Changed 11 years ago by Artur Formella

Keywords: Confirmed added; Pending WorksForMe removed

Changed 11 years ago by Artur Formella

Attachment: 2191.patch added

comment:13 Changed 11 years ago by Artur Formella

Keywords: Review? added

Finally I found a way to fix this bug. MediaWiki has strange problem with default values set outside of DefaultSettings.php

comment:14 Changed 11 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed
Resolution: fixed
Status: reopenedclosed

Fixed with [3234].

The patch was ok, it contained just one little problem - it wasn't E_NOTICE friendly (lack of isset/empty calls).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy