Opened 3 years ago

Closed 3 years ago

#14728 closed Bug (wontfix)

No way to stop showing the red flag separately

Reported by: Ron Yu Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.5
Keywords: Cc:

Description

Html source code containing "<a name=”quotes”></a>" displays a red flag. No way to put off it, unless we disable "link" plugin as follows, config. removePlugins: 'link

Steps to reproduce

  1. Copy the text from the attached file
  2. Paste into CKEditor

Expected result

Please provide a config method to put off red flag, while "link" is enabled.

Actual result

Could only disable red flag by disable "link" plugin.

Other details (browser, OS, CKEditor version, installed plugins)

OS: Windows 8.1 CKEditor version: 4.5.5 Occurs on demo site: yes

Attachments (1)

TextContainingAnchor.docx (10.8 KB) - added by Ron Yu 3 years ago.
Text containing empty anchor

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by Ron Yu

Attachment: TextContainingAnchor.docx added

Text containing empty anchor

comment:1 Changed 3 years ago by Ron Yu

Seeking for a solution to put off red flag. Red flag sometimes will make confusion, when we pass some text to CKEditor and it will show red flag we don't notice in other editors. Thanks.

comment:2 Changed 3 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed

it will show red flag we don't notice in other editors.

This is how anchors are presented in the editor. This is how this plugin works. We can't add config option for icon because it is not just about icon. The anchor gets cke_anchor class which is in fact hardcoded inside the plugin.

If you want to change it, you can:

  1. Change the anchor.png icon available under ckeditor\plugins\link\images to some other with the same name (don't forget to clear browser's cache). This can be done in release package.
  2. If you want to change whole class you need to edit this plugin. You can get source code from here: http://docs.ckeditor.com/#!/guide/dev_source,
    make changes here:
    https://github.com/ckeditor/ckeditor-dev/blob/master/plugins/link/plugin.js#L18-L19,
    https://github.com/ckeditor/ckeditor-dev/blob/master/plugins/link/plugin.js#L31-L40
    and finally build your CKEditor release according to http://docs.ckeditor.com/#!/guide/dev_build.

NOTES:

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy