Opened 3 years ago

Closed 3 years ago

#14751 closed Bug (wontfix)

if the p element is styled in a certain way, the paragraph cannot be deleted in IE and Edge

Reported by: Sergelie Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.5
Keywords: Cc: Sergelie

Description

Steps to reproduce

  1. add this code in the editor style sheet :

p { font-size:32px; border: dotted 1px #818181; overflow:auto; line-height:normal; width:97.5%; padding:10px;}

  1. try to delete the paragraph when it is empty - you cannot.
  1. You have to delete it via the source.

Other details (browser, OS, CKEditor version, installed plugins)

bug in Edge and IE 10 (not in Chrome or FF) not related to plugins. version 4.5.5

The issue seems to be related to the attr. overflow and/or width in %.

Attachments (1)

borderHasLayout.png (28.9 KB) - added by Jakub Ś 3 years ago.

Download all attachments as: .zip

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Component: Core : StylesGeneral
Keywords: Styling Edge IE removed
Resolution: wontfix
Status: newclosed

Checked in CKEditor 4.5.10

  1. When you are using default enterMode set to P then you can't remove paragraph in any browser which is ok because you need a starting point.
  2. When you are using enterMode set to BR and you insert such paragraph then yes "it is not possible" to remove it because hasLayout. There is nothing we can do in such case because this is IE "feature". Both properties you have mentioned can cause this. Here are some old articles about it: http://www.satzansatz.de/cssd/onhavinglayout.html or https://msdn.microsoft.com/en-us/library/bb250481(v=vs.85).aspx.
  3. I have written "it is not possible" because although it is not possible with Ctrl+A Delete, it is possible with selecting the paragraph in elements path (provided that enter mode is not P) and pressing delete. Please click on P in elements path and press delete or backspace.

@Sergelie I belive this is what you are getting and I will close this as a won't fix issue. If that is not your case at all, please describe it in more detail and I will reopen it.

Changed 3 years ago by Jakub Ś

Attachment: borderHasLayout.png added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy