Opened 3 years ago

Closed 3 years ago

#14781 closed Bug (invalid)

browser is unresponsive when single page has too many iframed ckEditor instances

Reported by: jignesh.dalwadi Owned by:
Priority: Normal Milestone:
Component: Performance Version:
Keywords: Cc: jignesh.dalwadi@…, premal.lathiya@…

Description

Hi, We are using CKEDITOR 4.4.8 (revision:ccd0038). In our application we have a page which have 222 iframed CKEditor instances. When we load this page in IE 11 and chrome, browsers responds very very slowly. In case of IE 11 we get alert like '.. not responding due to long running script.' for this page loading.

When we traced browser log, we found multiple calls to contents.css. We noted that all these calls of contents.css are provided from cache by browser but the issue is CKEDITOR calls multiple times (in our case 222 times) to browser and that's making browser almost unresponsive.

We have already referred https://dev.ckeditor.com/ticket/10425.

Do you have any work around to prevent browser slowness when single page has such large iframed ckEditor instances?

Thanks.. Jignesh Dalwadi

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.10 (GitHub - master)

Having 222 editors on one page is too much IMHO. You should not have that many on one page. Everything has its limits and I think you have crossed this one. Here are suggestions on how to design the page and load CKEditor so that it gets loaded faster.

  • Shared space: http://sdk.ckeditor.com/samples/sharedspace.html - here the performance gain is caused by the fact that fewer changes in DOM are made as just a single toolbar instance is used.
  • Use inline editor instead of classic editor: http://sdk.ckeditor.com/samples/inline.html - inline editor is much lighter than the classic editor (which is using iframes and separate contents.css).
  • If you need to use classic editor - create & destroy instances on the fly on demand, when user needs to edit specific field.
  • Split the page with 222 editable elements into few steps (few pages). Thanks to that a simpler form will be less distracting for the user.

Hope any of the above helps. Anyway this is not editor issue but a problem with how your page/application was designed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy