Opened 3 years ago

Closed 3 years ago

#14824 closed Bug (fixed)

editor.editable parameter should be optional

Reported by: darkangel Owned by:
Priority: Normal Milestone: CKEditor 4.6.0
Component: Documentation & Samples Version: 4.0
Keywords: Cc:

Description

The element parameter is optional, but the doc comment does not indicate that.

The TypeScript definition is also incorrect (https://github.com/DefinitelyTyped/DefinitelyTyped/blob/54ae3cf3aa6156065d57e242f38e1e86bd0ed9bc/ckeditor/ckeditor.d.ts#L1088).

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Component: GeneralDocumentation & Samples
Status: newconfirmed
Version: 4.5.10 (GitHub - master)4.0

http://docs.ckeditor.com/#!/api/CKEDITOR.editor-method-editable
http://docs.ckeditor.com/source/editable.html#CKEDITOR-editor-method-editable

That is correct. You can call editor.editable() and no error will be thrown. Besides the code looks like this parameter is optional.

comment:2 Changed 3 years ago by Anna Tomanek

Milestone: CKEditor 4.6.0
Resolution: fixed
Status: confirmedclosed

Fixed with git:CC9647e.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy