Opened 3 years ago

Closed 3 years ago

#14839 closed Bug (duplicate)

Could not use some long hexadecimal code to have the name of the color in the tooltip

Reported by: cactus20100 Owned by:
Priority: Normal Milestone:
Component: UI : Skins Version: 4.5.11
Keywords: styling Cc:

Description

Steps to reproduce

  1. add plugin "color button" to CKEditor with Office 2013 theme
  2. Create a form like this :
<form style="margin-left: 80px;">
        <textarea name="editor1" id="editor1" rows="10" cols="80">
        </textarea>
        <script>
            var config = {
                language : 'en',
                height : '500',
                width : '600',
                colorButton_colors : 'FF0000,F00,FFFF00,FF0,00FF00,0F0,0FF,00FFFF'
            }
            CKEDITOR.replace('editor1', config);
        </script>
</form>
  1. Pass your mouse on every color of the color selector

Expected result

The colors are named in the tooltip, by order : Red, Red, Yellow, Yellow, Lime, Lime, Cyan, Cyan

Actual result

The colors are named in the tooltip, by order : FF0000, Red, Yellow, Yellow, Lime, Lime Cyan, 00FFFF

Other details (browser, OS, CKEditor version, installed plugins)

tested on IE11 (11.0.9600) and Firefox 47, on Windows 7 plugin color button : office 2013 theme tested on version 4.5.6 too.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This is the same case as #14838. Colors 0FF and F00 are in language files while FF0000 and 00FFFF are not.

I'm closing this ticket as a duplicate of #14838.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy