Opened 12 years ago

Closed 11 years ago

#1485 closed Bug (invalid)

IE: shift+enter brakes formatted text

Reported by: Georg Grabler Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Pending Cc:

Description

Hello,

I lately installed MediaWiki+FCKeditor from the SVN trunk (rev 1055). Once again, as always, I'm experiencing problems with linebreaks and pre tags. The topic is getting annoying, but i tried quite every patch available here, and either they were already applied or they simply don't work as intended.

I'll go trough usecases, for IE 6.0 and Gecko (FireFox). I'm using FireFox 2.0.0.8 on Linux (Gecko 20071020).

Usecase 1 - Add normal text and apply Formatted to it

I write text normally, using SHIFT+Enter for the linebreak. I select the whole text i've written and apply the format "Formatted". It displays the text nicely, as expected by me. Now, by pressing on "Wikitext", the following happens:

Internet Explorer: Internet explorer completely behaves as intended. Switching around does not screw up anything.

Firefox Firefox behaves differently. Switching the first time to wikitext, the following text is displayed:

<pre>test<br>testt<br>testtest</pre>

Switching back, this linebreaks show up in the wikitext in a format block Next time i switch to the wiki text, the following is displayed:

<pre>test&lt;br&gt;testt&lt;br&gt;testtest</pre>

Which was not intended by me. No need to mention that the linebreaks were lost within the pre block by the first time switching.

Usecase 2: Editing already formatted text

Well, i created a page, formatted it, and did NOT switch to the wikitext. I saved the page, and went on "edit", or use the "preview" function. Now, i add up some line, the following happens

Internet Explorer The internet explorer on the first shift + enter won't let me add any line. Instead of this, IE adds some pre tags (shift+enter?)

<pre><pre>test
testtest
testtesttest</pre><pre></pre></pre>

By switching back, the view is screwed up (of course).

If i press new line, and start writing (note: the curser did NOT switch to the next line yet), it works properly.

If i add something pressing two times SHIFT + Enter, the pre tags get screwed up again:

<pre><pre>test
testtest
test
testt</pre><pre></pre>

test</pre>

Firefox Doing the same with firefox, firefox again screws up the newlines with br (of course), as described in usecase 1. For the field added (the newline), firefox does the following:

<pre>test<br>testt<br>testtest test</pre>

which means it does not convert the newline into a break anymore, but a blank instead of that. It does not screw up the pre tags though, as IE does.

I hope you can reproduce this problems.

Yours, Georg

Change History (4)

comment:1 Changed 12 years ago by Georg Grabler

Urks, was for the category MediaWiki + FCKEditor. Can anyone forward this to the right category? It seems as if i can't do that anymore :(.

Sorry, Georg

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralProject : MediaWiki+FCKeditor
Keywords: pre tags linebreak removed
Priority: HighNormal

comment:3 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending added
Summary: Firefox, IE, <pre>, LinebreaksIE: shift+enter brakes formatted text

Using SVN revision 1453

Usecase 1
I can't confirm the bug. It works fine on IE, IE7, FF2. Try to download the latest SVN version and see if you have the expected results. Usecase 2
I can confirm this bug but only partially. It works fine on IE7 and FF2. However in IE6 the problem occurs probably the same way as in your example.

<pre>line 1
line2
line3
</pre>

is changed to:

<pre><pre>line1</pre><pre></pre>
new line added
line2
line3</pre>

So could please check the newest revision and Usecase 1. you may also use our Sandbox http://mediawiki.fckeditor.net/index.php/Sandbox

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed

Expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy