Opened 3 years ago

Closed 3 years ago

#14853 closed New Feature (duplicate)

Redesigning link and image menus for simplicity

Reported by: tmaly1980 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi,

I've been looking for a good rich text editor to use in my Rails-based content management systems (used by non-technical users) and although the toolbar can be configured well, I'd really wish there was some thought put to making the menus for links and images more user-centric. They still have a 1990's feel with all the options and input fields, which is really over the head of MOST people. It needs rethinking for simplicity's sake.

For links, there really should be no more than the text, the URL, and whether to open in a new window. People rarely manually type in a URL. They paste URLs into the editor. Realistically it should automatically make into a link if it detects the proper format. The link menu doesn't need a protocol - nobody understands what that is anyway, and when people paste a url, they hardly do so without the protocol. Just have a single string be whatever they want it to be, including the protocol. The tabs in the link menu are cumbersome and most of the options are rarely used by anyone who isn't already technical. At the very least, make an option to simplify the menu with a minimalist version. If the link looks like an email, then it should prepend "mailto:" to the URL when first typing (but not after they remove it again), maybe have a small note saying why. And if the selection looks like any sort of url (whether a link or an email), it should AUTOMATICALLY place that content inside the URL field. Make it easy on the user.

The image menu has the same issues. Why ask for a URL at all? Using links from other sites will break the page if they go down from their original source, so why not assume the user will just save a copy and re-upload? Alignment, width/height, etc should be handled purely by the main editor interface - visually. Shrinking/stretching the image as needed, clicking on the toolbar's alignment buttons to adjust alignment. Minimize the image menu for just uploading (and maybe other minor options). Move everything to a single tab and make it easy on the user.

At the very least this should be a configuration option even to simplify/minimize if you still want to offer the overkill (and IMO outdated) dialog boxes.

The problem with open source software refusing to make decisions about cutting out features/options in the hopes of not excluding anyone from any possible use cases is that it overcomplicates things for most use cases. Development at this day and age is about getting things done quickly and simply, so I'd hope for at least a simple configuration option to provide a very common use case so I don't have to spend a day hacking at the source code. Developers don't have the time for that anymore when customers are expecting a high quality level of products/services.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

The image menu has the same issues.

All things mentioned in that paragraph are handled by image2 plugin which is a simplified version of classic image plugin.

At the very least this should be a configuration option even to simplify/minimize if you still want to offer the overkill (and IMO outdated) dialog boxes.

But there is dialog api which allows just that - you can remove fields and tabs you don't want to have in your dialog. There is no need to hack the source code - just use the api - http://docs.ckeditor.com/#!/api/CKEDITOR.dialog and http://docs.ckeditor.com/#!/api/CKEDITOR.dialog.definitionObject.

Realistically it should automatically make into a link if it detects the proper format.

Please see http://ckeditor.com/addon/autolink

I can only agree with making link dialog simpler. I haven't found any such report so it's worth reporting it in a separate ticket - #16338

I will close this one as duplicate of #16338

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy