Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14854 closed Bug (invalid)

[Chrome] Error when using Chrome, Undo Plugin, inline mode

Reported by: Eric Schripsema Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Force the sample to create an inline editor
  2. insure the undo plugin is enabled
  3. use tool to insert table
  4. click ok

Expected result

Correct insert of table with out error

Actual result

Table inserted, but JS error prevents close of dialog

Other details (browser, OS, CKEditor version, installed plugins)

Tested under other browsers, no error occurs.

Other plugins installed (from config): dialogui,dialog,about,a11yhelp,dialogadvtab,basicstyles,bidi,blockquote,clipboard,button,panelbutton,panel, floatpanel,colorbutton,colordialog,templates,menu,contextmenu,div,resize,toolbar,elementspath,enterkey, entities,popup,filebrowser,find,fakeobjects,flash,floatingspace,listblock,richcombo,font,forms,format, horizontalrule,htmlwriter,iframe,wysiwygarea,image,indent,indentblock,indentlist,smiley,justify, menubutton,language,link,list,liststyle,magicline,maximize,newpage,pagebreak,pastetext,pastefromword, preview,print,removeformat,save,selectall,showblocks,showborders,sourcearea,specialchar,scayt, stylescombo,tab,table,tabletools,undo,wsc,lite,base64image,lineutils,widget,chart

JS Stack:

range.js:798 Uncaught TypeError: Cannot read property 'type' of nullbetweenTextNodes

@ range.js:798 normalizeTextNodes @ range.js:818 CKEDITOR.dom.range.createBookmark2 @ range.js:929 createBookmarks2 @ rangelist.js:150 createBookmarks2 @ selection.js:2060 CKEDITOR.plugins.undo.Image @ plugin.js:798 save @ plugin.js:367 (anonymous function) @ plugin.js:76 listenerFirer @ event.js:144 CKEDITOR.event.fire @ event.js:290 CKEDITOR.editor.fire @ editor_basic.js:24 (anonymous function) @ plugin.js:340

Change History (6)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: chrome undo inline removed
Status: newpending
Version: 4.5.11
  1. Are you able to reproduce this issue on demo page or with default and standalone CKEditor freshly downloaded from our page? This is important to exclude any possible influence of custom third-party CKEditor plugins as well as third-party scripts that you might be using inside your application.
  1. What exactly is the test case here? From what you have written it looks like it is enough to insert table or type and insert table and error should be thrown. I have tried default CKEditor and nothing like that has happened.
    Could you describe this test case in more detail or could you perhaps provide jing video showing how to reproduce this problem?

comment:2 Changed 3 years ago by Eric Schripsema

The demo page is a not a problem ... but the CKEDITOR with the download using builder create an environment that causes this ... I tracked it down, with a little more insight.

Starting with a "Full" setting and adding the "LoopIndex Track Changes". And then downloading. You then have to modify the sample.js so that it creates an inline editor rather than a replacement. Then I just add a table. Anything less than full doesn't seem to cause the issue some it is no doubt some conflict between the track changes and some other standard plugin. This error does not happen when you aren't doing the inline editor.

//if ( wysiwygareaAvailable ) {
//	CKEDITOR.replace( 'editor' );
//} else {
	editorElement.setAttribute( 'contenteditable', 'true' );
	CKEDITOR.inline( 'editor' );
	// TODO we can consider displaying some info box that
	// without wysiwygarea the classic editor may not work.
//}

comment:3 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Please note that http://ckeditor.com/addon/lite is a third-party plugin not created by CKSource. We can't and don't support that plugin in any way.

If this plugin is causing problems for you, you need to report it to plugin author.

comment:4 Changed 3 years ago by Eric Schripsema

Just a followup.... It turns out that the two incompatible plugins are Undo and the Track Changes.

comment:5 Changed 3 years ago by Jakub Ś

Please report this to the plugin author - custom plugins need to be adjusted to CKEditor and its core features and not the other way around.

comment:6 Changed 3 years ago by Eric Schripsema

I did... the first time you mentioned it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy