Opened 3 years ago

Closed 2 years ago

#14858 closed Bug (invalid)

drag drop does not allow undo

Reported by: RobC Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version:
Keywords: Cc:

Description

Using latest full version of ckeditor ( 4.5.11 downloaded yesterday )

  1. create a left floating div 33% width using a custom style
  2. create a a paragraph inside div
  3. put an image inside above paragraph with custom style of 100% width so it scales to width of 33% div.
  4. than drag and drop image fully or partially outside of div.
  5. select moved image
  6. use ctrl+z or undo button to put image back

Expected result

image should go back to where it was.

Actual result

ctrl+z doesn't undo the change undo button is not available not active

Other details (browser, OS, CKEditor version, installed plugins)

windows 7. ckeditor 4.5.11 full version just youtube plugin added.

the drag drop adds style="left:nn; top:nn;" to the dragged element as expected but that doesn't seem to be recorded in the undo list so that ctrl+z or undo button can't do their stuff.

thanks

Change History (3)

comment:1 Changed 3 years ago by RobC

Component: GeneralCore : Undo & Redo

comment:2 Changed 2 years ago by Tade0

Status: newpending

Does this error occur in any specific browser?

comment:3 Changed 2 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I can't reproduce this issue as well. @roblitody please provide screen cast showing how to reproduce this problem in default CKEditor and we will consider reopening this issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy