Opened 3 years ago

Closed 3 years ago

#14864 closed Bug (invalid)

Chrome copy/paste issue

Reported by: Sean Chapman Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Description

When using chrome and typing something into a new WebMail (Our Company uses ckeditor for mailing) and then wanting to copy and paste information, the copy/pasted information is always pasted at the top of the message instead of where the cursor last was.

It was found that this only affects users that have an email signature setup within ckeditor.

Steps to reproduce

  1. Open a new WebMail (This user must have an email signature)
  2. type a message
  3. Move the cursor below the message
  4. Copy/Paste text from another source like word or notepad
  5. Notice that the pasted text is now at the top of the message

Expected result

The pasted text should be pasted where the cursor is

Actual result

The pasted text is sent to the top of the message before the origonal

Other details (browser, OS, CKEditor version, installed plugins)

I am not sure of the version, but this only affects users who use the Chrome web browser.

Attachments (4)

signature.PNG (29.2 KB) - added by Sean Chapman 3 years ago.
Signature
typedmessage.PNG (42.2 KB) - added by Sean Chapman 3 years ago.
Original message
newCursorPlacement.PNG (21.5 KB) - added by Sean Chapman 3 years ago.
cursor placement right before pasting copied text
pastedTextAtCursor.PNG (38.3 KB) - added by Sean Chapman 3 years ago.
pasted text from notepad

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by Sean Chapman

Attachment: signature.PNG added

Signature

Changed 3 years ago by Sean Chapman

Attachment: typedmessage.PNG added

Original message

Changed 3 years ago by Sean Chapman

Attachment: newCursorPlacement.PNG added

cursor placement right before pasting copied text

Changed 3 years ago by Sean Chapman

Attachment: pastedTextAtCursor.PNG added

pasted text from notepad

comment:1 Changed 3 years ago by Jakub Ś

Status: newpending

I am not sure of the version

Please check ckeditor/CHANGELOG.html. Your version is at the very top. Could you tell me what it is?

From what I can see in your pictures there should be no webmail needed for that. You just need CKEditor with text entered when editor is loaded. Next you move that text down, type new one, you press enter and paste some content from notepad.

Is that correct? If yes then I have tried reproducing these steps and everything is working properly.


  1. Could you attach your config.js file to the ticket?
  2. If you are configuring CKEditor directly on HTML page, could you attach that HTML as well?
  3. Could you attach your build-conig.js file?
  4. Can this issue be reproduced on our demo page?

comment:2 Changed 3 years ago by Sean Chapman

To recreate you must first have a signature for the user. After the signature has been entered and saved you then compose a new message. You then type your message in the new email. You must them copy text from another source to your clipboard. In the message you now must move the cursor to the line in between your typed message and the signature. The copied text should then be pasted in the message. You should observe that the pasted text is moved to the top of the new email before your typed message.

Below is the error message that is returned when following the steps above.

Discontiguous selection is not supported. selectRanges @ ckeditor.js?v2015_i24:400 selectBookmarks @ ckeditor.js?v2015_i24:402 (anonymous function) @ ckeditor.js?v2015_i24:594

1, 2, 3. I will not be able to attach the file at this time without approval of the company. If you absolutely need this, let me know.

  1. No, the demo page does not allow signatures to be added.

comment:3 Changed 3 years ago by Jakub Ś

After the signature has been entered and saved you then compose a new message.

CKEditor has nothing to do with saving data. This is JS application so it should be possible to recreate this problem without the server-side involved.

To recreate you must first have a signature for the user

From what I have seen in your signature.PNG, the signature is just a plain text so it order to reproduce the problem on e.g. demo page or standalone CKEditor it should be enough to load editor with initial content like single word or few words and the type, copy/paste the rest. Would you agree with that? If not, what exactly is the signature - is it some kind of special HTML? What is so special about it because it really looks to me like initail text and nothing else?

comment:4 Changed 3 years ago by Sean Chapman

I am not able to recreate the issue in the demo below is the 'source' that is given to me in my ckeditor.

<div>&#160; <div>&#160; <div>This is a signature</div> </div> </div>

When i paste this signature in your demo i get the source

<p><br /> </p>

<p>This is a signature</p>

Do you think that this is the cause of the issue?

comment:5 Changed 3 years ago by Jakub Ś

You are using div enter mode in your application most likely. There is a demo sample for it: http://ckeditor.com/demo#enter.

I have tried a demo and I have tried default CKEditor with with div enter mode set. None of them has given the result you are talking about. Are you able to reproduce this problem on div enter demo or in standalone editor configured just like editor in your application?

If you are not able to reproduce this problem, it is possible that that it is related to some third-party plugin you use with the editor or third-party script which is conflicting with your editor.

comment:6 Changed 3 years ago by Sean Chapman

I am unable to reproduce this issue in the div enter mode link that you provided me. I will continue to investigate.

comment:7 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

In order to accept a bug we need clear reproduction steps in standalone CKEditor. At present I can't accept this ticket and will have to close it as invalid. If you find such scenario, please comment and ticket will be reopened.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy