Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14865 closed Bug (wontfix)

In Internet explorer, if the container that holds the ckeditor is draggable, you cannot select text within ckeditor.

Reported by: mpaige Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

Here is a sample app that demonstrates the behavior. Open it in Internet Explorer 11

http://jsbin.com/soratiraru/1/edit?html,js,console,output

Expected result

I expect the elements within ckeditor to remain selectable/movable.. etc.

Actual result

It tries to drag the object instead of selecting text within.

Other details (browser, OS, CKEditor version, installed plugins)

IE 11, CDN Standard version... Jquery... It works fine in Chrome.

Change History (3)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed

Please see: http://jsbin.com/dayipudazu/1/edit?html,js,console,output or if the result is not visible anymore please do the following:

//comment:
//CKEDITOR.replace($('.ck')[0]);
<!--<script src="//cdn.ckeditor.com/4.5.11/standard/ckeditor.js"></script>-->

//change cke div to 
<div class="ck" style="width:500px; height:300px; border:1px solid black;" contenteditable="true">

You will get exactly same result with native contenteditable element. Since this is happening with native element there is nothing we can do.

This is mostlikely browser issue.

Last edited 3 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 3 years ago by mpaige

Nice to know. Thanks. I'll try to come up with a temporary workaround. I have had a little success with setting draggable="false" via jquery selectors on the editable divs that ckeditor creates, but that causes elements inside not to be draggable, so not a great workaround. I might be able to refine my selectors a little more though.

comment:3 Changed 3 years ago by Jakub Ś

I have had a little success with setting draggable="false"

I you had little success then perhaps this isn't IE problem like I have assumed but rather jQuery problem which is too aggressive for contenteditable on IE. Anyway there is not much CKEditor can do here. Sorry.

If you would like to share once you find a solution, you are welcome to leave a comment.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy