Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14885 closed Bug (invalid)

Special characters are being altered when the language is set to arabic

Reported by: Mohamad Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.7
Keywords: Cc:

Description

Steps to reproduce

  1. Set Arabic in the configuration.
  2. Write in Arabic at first.
  3. Write an English word between () or {}.
  4. write an English word after it directly.

Expected result

The 2nd word should remain outside the brackets.

Actual result

The word is inside the bracket.

Other details (browser, OS, CKEditor version, installed plugins)

Browser: Google Chrome
OS: Windows 10

Change History (3)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: Arabic to english removed
Resolution: invalid
Status: newclosed

I assume that by saying "Set Arabic in the configuration" you mean CKEditor configuration.

If that is the case then please try typing "}in{behind" in below container used on standard HTML5 page and you will get same result.

<div style="margin:20px; border:1px solid black; width:500px; height:200px;" contenteditable="true" dir="rtl">	

</div>

If however you write "{in}behind" you will get correct but mirrored result.


The bottom line is that you should not use LTR languages in RTL containers because you will get strange results. What is more those results are given by the browser and not by the editor.

comment:2 Changed 3 years ago by Mohamad

Many thanks :D I managed to fix it in chrome and Firefox by simply adding an invisible Arabic character after {in} so it worked, but for IE, it did not work.

comment:3 Changed 3 years ago by Jakub Ś

I don't think this is a fix but rather a lucky hack. Like I have said before - this is something controlled by the browser and you should not use LTR languages in RTL containers because you will get such weird results.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy