Opened 12 years ago

Closed 12 years ago

#1528 closed Bug (duplicate)

Backspace or delete key inserts new paragraph/line break

Reported by: Clay Shaw Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Confimed Cc:

Description

When you edit an existing paragraph, click after a character, and press the Backspace or Delete key </p><p><br/> gets inserted into the HTML. The display looks fine; however, when you saved or switch to Wikitext mode the the word is split on two lines.

Bug happens on MediaWiki+FCK Extension. Not sure what version of FCKEditor it uses.

Change History (6)

comment:1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Keywords: Backspace Delete Keystroke removed
Milestone: FCKeditor 2.5
Priority: HighNormal
Version: FCKeditor 2.4SVN

comment:2 in reply to:  description Changed 12 years ago by cbortkowski7

Replying to cyshaw:

When you edit an existing paragraph, click after a character, and press the Backspace or Delete key </p><p><br/> gets inserted into the HTML. The display looks fine; however, when you saved or switch to Wikitext mode the the word is split on two lines.

Bug happens on MediaWiki+FCK Extension. Not sure what version of FCKEditor it uses.

I notice this bug too. It seems it only does it if you click or move the cursor before/after a character and press the Backspace/Delete key. It works fine if you select the whole word and press the Backspace/Delete key though.

comment:3 in reply to:  description Changed 12 years ago by SJB

I believe this only happens with Internet Explorer. Firefox doesn't seem to add these.

comment:4 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

Hi! I can't reproduce the bug you are describing. Everything works for me so could please write a more detailed instruction with steps that should be taken to reproduce the bug or possibly attach an example code. Also could you check if the bug occurs here http://mediawiki.fckeditor.net/index.php/Sandbox. Thanks

comment:5 in reply to:  4 Changed 12 years ago by Jon

  1. using internet explorer 6, go to http://mediawiki.fckeditor.net/index.php/Sandbox and click the edit button.
  2. type the sentence "Don't use the ddelete key"
  3. go back and delete (not backspace) the extra d: "Don't use the delete key",
  4. save it or look at the wiki text version and you get

"Don't use the d

elete key"

(notice the extra line between d and elete)

comment:6 Changed 12 years ago by Wojciech Olchawa

Keywords: Confimed added; Pending WorksForMe removed
Resolution: duplicate
Status: newclosed

Thanks for your description. Ticket #1547 has the same bug, but a little better history so I'm marking this one as DUP of #1547.

All info about this bug will be placed there.

Thanks for your help.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy