Opened 12 years ago

Closed 11 years ago

#1539 closed Bug (worksforme)

Show Preview wraps entries with <p> and </p>

Reported by: fayeatot Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Pending WorksForMe Cc:

Description

I installed the FCKEditor extension for Mediawiki(1.10.2). I noticed that whenever I edit a page, use "Show Preview" then "Save Page", the page formatting is messed up. Everything is displayed in one line. Instead of headers, it shows

== 1 == 1111 == 2 == 222

all in one line.

I've found out (by using "Show Changes") that the text I had was wrapped with <p> and </p>, which is probably why they are displayed that way.

I'm not sure if this is a bug or a setting that I need to adjust.

Change History (7)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

Hi! I couldn't reproduce your problem either on IE or FF. Could you please check out our Sanbox http://mediawiki.fckeditor.net/index.php/Sandbox and try to reproduce this problem there and than let us know if it still occurs Thanks!

comment:2 Changed 11 years ago by Andrew Forman

I ran into the same problem and was able to track it down to an incorrect modification of the includes/EditPage.php. In my case, it was the last modification step for that file -- I had made the modification too early in the file (around line 1433 rather than around line 1465). Once I corrected the error the preview functionality operated properly (as it does at the sandbox site).

comment:3 Changed 11 years ago by Dr. Sharad Kelkar

Persistent problem noticed even in IE7 and Safari, and other browsers that extra unwanted <p> get inserted around editor text when you switch back and forth between source view and WYSIWYG mode.

comment:4 Changed 11 years ago by Wojciech Olchawa

It still works fine to me. Have you tried to update do the latest version of FCKeditor? Please let us know what version of FCKeditor and MW do you use?

Thanks.

comment:5 Changed 11 years ago by Wojciech Olchawa

Ignore my previous post. Try to update to the latest version of FCKeditor extension for MediaWiki. You can download it from here:

http://svn.fckeditor.net/MediaWiki/trunk/

and than let us know if you still have wrong results.

Thanks.

comment:6 Changed 11 years ago by testme7

No reply since 3 months, so I'm closing this ticket.

comment:7 Changed 11 years ago by Wiktor Walc

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy