Opened 12 years ago

Closed 8 years ago

#1540 closed Bug (worksforme)

wrapping paragraph or ending br for new content, (Shift)EnterMode to 'br'

Reported by: Paul Moers Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5 Beta
Keywords: Cc:

Description

The FCKeditor in IE wraps new content in p tags (I have set both EnterMode and ShiftEnterMode to 'br'), also firefox sometimes ends the new content with a br tag.

Desired behavior
The behavor I'm looking for is a combination of Firefox and IE. When removing all content, I want the newly entered text not marked up, no wrapping p tags nor ending br tags.

Firefox 2.0.0.9 behavior, FCKeditor 2.5 Beta Build 16848

  • Overtyping the text (select all and type) works fine.
  • But when removing the text first (select all, backspace or delete, then type) a <br /> tag is being inserted at the end.
  • Removing all content by using backspace (not selecting all, but hitting backspace untill all content is removed, then type) works too.
  • Removing all content by using del (again not selecting, but using del until all content is removed, then type) wraps the content in p tags and inserts two spaces (&nbsp; ) before the content.

IE (6 & 7) behavior, FCKeditor 2.5 Beta Build 16848
This is almost the opposite of Firefox.

  • Overtyping the text (select all and type) wraps the content in p tags.
  • Removing the content first (select all, backspace or delete, then type) works fine.
  • Removing all content by using both backspace or del (not selecting all, but hitting backspace or del untill all content is removed, then type) works fine.

Change History (8)

comment:1 Changed 12 years ago by Paul Moers

For what it's worth, a description of FCKeditor 2.4.3 its behavior with EnterMode and ShiftEnterMode to 'br'.

Firefox 2.0.0.9, 2.4.3 Build 15657

  • select all + type is oke
  • select all + backspace or del is oke
  • backspace or del until all content is removed + type is oke

IE 6 & 7, 2.4.3 Build 15657

  • select all + type wraps content in p tags
  • select all + backspace or del wraps content in p tags
  • backspace or del until all content is removed + type wraps content in p tags

(I believe it does work, when the FCKeditor is loaded without content and content can be entered right away)

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: paragraph br EnterMode ShiftEnterMode removed

comment:4 Changed 12 years ago by Paul Moers

For FCKeditor 2.5 final (FCKeditor 2.5 Build 17352), the behavior remained almost the same.
Changed behavior is marked bold

Firefox 2.0.0.11 behavior, FCKeditor 2.5 Build 17352

  • Overtyping the text (select all and type) works fine.
  • But when removing the text first (select all, backspace or delete, then type) a <br /> tag is sometimes being inserted at the end, see additional info below.
  • Removing all content by using backspace (not selecting all, but hitting backspace until all content is removed, then type) works sometimes, see additional info below.
  • Removing all content by using del (again not selecting, but using del until all content is removed, then type) work sometimes (the two spaces ('&nbsp; ') don't appear anymore), see additional info below.

IE (6 & 7) behavior, FCKeditor 2.5 Build 17352

  • Overtyping the text (select all and type) wraps the content in p tags.
  • Removing the content first (select all, backspace or delete, then type) works fine.
  • Removing all content by using both backspace or del (not selecting all, but hitting backspace or del until all content is removed, then type) works sometimes, see additional info below.


Some additional info:
Ah it seems that when you remove the text with backspace/del there are two possibilities: Pressing backspace/del just enough times to remove the content and then typing makes your newly typed text being wrapped in p tags. Only when you press backspace/del at least one time more, you'll get your plain content.
Something similar happens, in firefox, when you select all then delete by using delete: Just a single hit before typing will insert this <br /> tags at the end as described above. Pressing it at least two times gives you the plain content. When using backspace, pressing it extra times doesn't help. Selecting all and delete always works fine in IE, also when pressing just once.

comment:5 Changed 12 years ago by Wojciech Olchawa

Keywords: Confimed added

Confirmed.

Some additional info: in IE overtyping the text gives also another unexpected behavior. Besides adding the <p> tag font style also appears:

<p><font style="background-color: #ffa500">Ticket 1540 test</font></p>

comment:6 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed added; Confimed removed

comment:7 Changed 12 years ago by Julia

I'm interested too. (If this bug really corresponds to my problem, I will give details too as soon as possible)!

comment:8 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy