Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#1541 closed Bug (fixed)

Disable auto tag closing in Mediawiki fckeditor extension

Reported by: Jaamit Durrani Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Fixed Cc:

Description

Hi,

I am using the FCKeditor extension for mediawiki in combination with an extension called ArticleComments which enables guestbook style comments with the inclusion of a <comments /> tag anywhere on a page.

The problem is that FCKeditor automatically changes <comments /> to <comments></comments>, which stops the ArticleComments extension from working properly.

Is there any way to disable this automatic closing of tags so <comments /> stays as it is?

I'm working to quite a strict deadline to provide a customised mediawiki interface for a client and I would really appreciate some speedy assistance

Thanks

Jaamit Durrani jaamit.durrani@…

Attachments (1)

1541.patch (1.0 KB) - added by Artur Formella 11 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 in reply to:  description Changed 11 years ago by Jaamit Durrani

Replying to jaamit:

PS - I have tried adding the following lines to both mediawiki\extensions\FCKeditor\fckeditor_config.js and to mediawiki\extensions\FCKeditor\FCKeditor\fckconfig.js:

FCKConfig.ProtectedTags = 'COMMENTS|COMMENTS/' ; FCKConfig.ProtectedSource.Add( /<comments:.*>/g ) ;

Not sure if the syntax is correct but this does not resolve the problem - <comment/> still changes to <comment></comment>

comment:2 Changed 11 years ago by Jaamit Durrani

OK I have just noticed another bug which makes this problem even more of a nightmare. Everytime a page containing the <comment/> tag is edited (or every time I simply switch between wsywig and wikitext), another set of <comment></comment> tags is added! 10 edits later, you end up with a page full of "Leave a comment..." (from the ArticleComments extension) links!! I REALLY need a way to stop FCKeditor messing with this tag- someone please help.

Jaamit

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: disable auto self closing tags removed
Priority: HighNormal

comment:4 Changed 11 years ago by Wojciech Olchawa

Resolution: wontfix
Status: newclosed

Hi!

If the auto tag closing was disabled it could make even worse damage. Let's say that someone forgets to close the tag than the whole text which appears after the first tag would be formatted incorrectly. It would make things even worse.

comment:5 Changed 11 years ago by Tim Bartel

Resolution: wontfix
Status: closedreopened

While the conclusion ("Disable auto tag closing in Mediawiki fckeditor extension") is wrong, the problem should be adressed.

The behaviour of the ArticleComments extension is not unusual. I had the same problem with the Bibwiki extension (http://www.plaschg.net/bibwiki/) which creates a bibliography via the <bibreferences/> tag. This also stop working when editing the article via FCKeditor, because it's converted to <bibreferences></bibreferences> which won't work.

I solved it by taking a look at ticket #1437 - and doing similiar changes to the files mentioned in changeset [1834] to bibreferences (which are there done for references).

Changed 11 years ago by Artur Formella

Attachment: 1541.patch added

comment:6 Changed 11 years ago by Artur Formella

Keywords: Review? added

comment:7 Changed 11 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

comment:8 Changed 11 years ago by Artur Formella

Keywords: Fixed added; Review+ removed
Resolution: fixed
Status: reopenedclosed

Fixed with [2457]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy