Opened 12 years ago

Closed 12 years ago

#1581 closed Bug (invalid)

IE7: responseText is null or is not an object (0 things found)

Reported by: B_aniaczek Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Pending Cc:

Description

Only MSIE7.0 (my version 7.0.5730.11 pl)

Select "Insert picture" or "Insert link" type something, which causes "no images found" or "no articles found" You will get an error: "responseText is null or is not an object".

To correct problem: In files image.html and link.html inside function LoadSearchResults( result ) replace line:

var results = result.responseText.Trim().split( '\n' ) ;

with

var results = ( result.responseText ? result.responseText.Trim().split( '\n' ) : '' );

Change History (4)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending added

Hi! I can't reproduce your bug. Could you please write what version of MediaWiki+FCKeditor are you using? Try to test it in the sandbox http://mediawiki.fckeditor.net/index.php/Sandbox and see what results do you have.

comment:2 Changed 12 years ago by B_aniaczek

It's true. I can't reproduce here. Bue: may be it is important: I'm using mediaWiki 1.11.0 instead 1.10

comment:3 Changed 12 years ago by Wojciech Olchawa

I've tried to reproduce it on mediawiki 1.11 as well and the problem still doesn't occur. Maybe you could provide some more info about this bug. Thanks!

comment:4 Changed 12 years ago by Wojciech Olchawa

Resolution: invalid
Status: newclosed

Ticket expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy