Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1586 closed Bug (fixed)

[IE] JavaScript error on edit

Reported by: Vince Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5 Beta
Keywords: Confirmed IE Cc:

Description

Is anyone able to solve that problem?

I have a major crash with IE 6 SP1 and Mediawiki+FCKeditor.

The crash happens when I change a certain bit of an article and when I press "save" or "wikitext". it is very disturbing as I don't know how to debug that.

You can reproduce the crash by following those steps in IE 6:

  1. go on http://mediawiki.fckeditor.net/index.php/TestMyBug : a new page I created

2.. change the title : e.g. remove the ':'

  1. click on 'wikitext' or on the 'save' button

... IE crashes !!

info : Windows 2000, IE 6.0.2800 SP1. works fine with Firefox 2

Attachments (3)

bug FCKeditor.jpg (151.8 KB) - added by Vince 10 years ago.
IE crashes on a simple Edit
1586.patch (565 bytes) - added by Frederico Caldeira Knabben 10 years ago.
Patch proposal
TC_1586.png (13.1 KB) - added by Wojciech Olchawa 10 years ago.

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by Vince

Attachment: bug FCKeditor.jpg added

IE crashes on a simple Edit

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Pending added; Internet Explorer crash removed
Milestone: FCKeditor 2.5
Priority: HighNormal

I was able to consistently reproduce this problem with IE6. It works well with IE7.

It is not an issue with FCKeditor, but with the MediaWiki plugin. I've debugged it, and found the culprit. I'm attaching a possible patch for it.

I haven't tested it. Could you please confirm that it solved the problem?

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 1586.patch added

Patch proposal

comment:2 in reply to:  1 ; Changed 10 years ago by Vince

It works!!!

Thank you sooooo much!

comment:3 in reply to:  2 ; Changed 10 years ago by Vince

Just one question : how did you find the bug ?

comment:4 in reply to:  3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Pending removed
Resolution: fixed
Status: newclosed

Replying to Vincent.cabs:

Just one question : how did you find the bug ?

Well... some intuition helped :) Let's say that I have a long experience on fighting browsers bugs :)

I've committed the fix to the SVN:
http://svn.wikimedia.org/viewvc/mediawiki?view=rev&revision=27935

comment:5 Changed 10 years ago by Wojciech Olchawa

#1935 has been marked as DUP

comment:6 Changed 10 years ago by Wojciech Olchawa

Resolution: fixed
Status: closedreopened

As for Vincent.cabs suggestion in #1935 I'm reopening this ticket.

comment:7 Changed 10 years ago by Wojciech Olchawa

Keywords: Pending added

I'm not able to reproduce this bug in IE6, but in WIN SP2.

comment:8 in reply to:  7 Changed 10 years ago by Vince

Replying to w.olchawa:

I'm not able to reproduce this bug in IE6, but in WIN SP2.

Go back to http://mediawiki.fckeditor.net/index.php/TestMyBug. You should be able to reproduce the bug with IE 6. Don't know why. Is there a charset problem ?

comment:9 Changed 10 years ago by Wojciech Olchawa

Keywords: Confimed IE added; Pending removed
Summary: IE 6 SP1 crashes on edit[IE] JavaScript erroe on edit

Confirmed in IE6 and IE7. I've attached a screenshot of the error. It's possible that we had a similar bug before but I'm no certain.

Changed 10 years ago by Wojciech Olchawa

Attachment: TC_1586.png added

comment:10 Changed 10 years ago by Wojciech Olchawa

Summary: [IE] JavaScript erroe on edit[IE] JavaScript error on edit

comment:11 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added; Confimed removed

comment:12 Changed 10 years ago by Wiktor Walc

Resolution: fixed
Status: reopenedclosed

I have committed patch provided by fredck (1586.patch) with [1820] and fixed the "object doesn't support this property or method" with [1821].

Other than that, it seems to be a problem to have two SVN repositories...

comment:13 in reply to:  12 Changed 10 years ago by Vince

It works, thanks very much !

comment:14 Changed 10 years ago by Wojciech Olchawa

#2026 has been marked as DUP

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy