Opened 11 years ago

Closed 11 years ago

#2026 closed Bug (duplicate)

IE6 + MediaWiki Extension: Minor edits within an existing line crash IE6

Reported by: Richard Bowmaker Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5.1
Keywords: Pending WorksForMe Cc:

Description

This occurs in both IE6 SP1 and SP2, on both Windows XP and 2000. FCKEditor version is 2.5.1

Steps to reproduce:

  1. In IE6, go to FCKEDitor + MediaWiki website sandbox
  2. Edit the sandbox page by adding the following line at the start (note the capital 'I'):

blah blah Integration blah blah

  1. Save the edit - this will work ok.
  2. Edit the page again, and change the capital 'I' to a lower case 'i'.
  3. Try to save this edit. Kaboom!

IE6 craches with an access violation.

Attachments (1)

FCKEditorIE6Crash.JPG (146.7 KB) - added by Richard Bowmaker 11 years ago.
Screen dump of crash

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by Wojciech Olchawa

Component: GeneralProject : MediaWiki+FCKeditor
Keywords: Pending WorksForMe added
Version: FCKeditor 2.5.1

Hi

I've tried to reproduce your problem but I only found that an additional <br> is added upon save. IE6 didn't crash at all. IE7 gave the same results. So could you please check the sanbox again or please let me know if I am missing something due to the reproduction.

Thanks in advance.

Changed 11 years ago by Richard Bowmaker

Attachment: FCKEditorIE6Crash.JPG added

Screen dump of crash

comment:2 Changed 11 years ago by Richard Bowmaker

Yes, I can still reproduce the problem in the sandbox using the above steps to reproduce exactly.

IE version is 6.2.2900.2180.xpsp_sp2_gdr.050301-1519, but I can also reproduce it on an earlier IE6 version too.

I tried it on IE7 (on a different PC) too, and got the extra line break.

comment:3 Changed 11 years ago by Richard Bowmaker

Perhaps if the extra <br> bug is fixed, that may also eliminate the crashing?

comment:4 Changed 11 years ago by Wojciech Olchawa

Hi again.

Could you please let us know if it is the IE6 version

6.2.2900.2180.xpsp_sp2_gdr.050301-1519

that you are using? Isn't it 6.0.2900.2180 ?

I've used 6.0.2900.2180.xpsp_sp2_gdr.070227-2254 for the tests and despite the <br> bug everything worked well.

Thanks in advance for the info.

comment:5 Changed 11 years ago by Richard Bowmaker

Sorry, the '2' was a typo...

the IE version is 6.0.2900.2180.xpsp_sp2_gdr.050301-1519

comment:6 Changed 11 years ago by Wojciech Olchawa

Hi again.

Thanks for the info. It seems that I'm unable to reproduce the bug because of the different compilations of IE6 that we have. I use a newer version (ver. from 27th February 2007).

If it wouldn't be a problem for you I would suggest upgrading to a newer compilation. But if you are unable to do so I will confirm this bug of course.

Thanks for you patience.

comment:7 in reply to:  6 Changed 11 years ago by Richard Bowmaker

Sorry for the delay.

I ran windows update, which installed an unrelated security update (KB944533), which didn't change the IE version at all. However the crashing has now gone away, and I just get the extra <br>. So this might be a hard one to pin down.

However, the extra <br> is still a real problem, and is probably related. Once it occurs, you have to go into WikiText to fix it, which kind of defeats the purpose of the editor. Do you know if a bug has been raised for the extra <br>? I'll see if I can find it.

comment:8 Changed 11 years ago by Richard Bowmaker

It looks like this is a duplicate of #1586 That ticket has a patch with it to fix the problem.

comment:9 Changed 11 years ago by Richard Bowmaker

The extra <br> problem is covered by several tickets. The main one seems to be #1547 . The suggested fix there is the same as for the crashing problem in #1586 i.e. Don't call Normalize() for IE.

comment:10 Changed 11 years ago by Wojciech Olchawa

Resolution: duplicate
Status: newclosed

The <br> is a different issue tough. Thanks for investigating. I will mark this one as

DUP of #1586

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy