Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16436 closed Bug (invalid)

Undo doesn't work properly

Reported by: Duskfall Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version:
Keywords: undo Cc:

Description

Steps to reproduce

  1. Open http://ckeditor.com/demo
  2. Clear all text inside
  3. Type a small text like "test"
  4. Select the "test text and copy it Ctrl + C
  5. Paste the selected text multiple times. At lease 4-5 lines
  6. Undo the input by pressing Ctrl + Z

Expected result

Undo all text

Actual result

The text is not undoed completely only partially

Other details (browser, OS, CKEditor version, installed plugins)

Tested on Firefox 49.0.1, Chrome 52.0.2743.116 m (64-bit) and IE 11

Change History (5)

comment:1 Changed 3 years ago by Duskfall

Component: GeneralCore : Undo & Redo

comment:2 Changed 3 years ago by Duskfall

Keywords: undo added

comment:3 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

It has always worked that way - this is by design.

There is a fixed number of characters recorded in one undo step: https://github.com/ckeditor/ckeditor-dev/blob/master/plugins/undo/plugin.js#L240-L245

comment:4 Changed 3 years ago by Duskfall

Is there a documentation or a reason why there is a limit in that? Did it fix some bug or something or shall I freely play with the value? Thanks

Last edited 3 years ago by Duskfall (previous) (diff)

comment:5 Changed 3 years ago by Jakub Ś

We definitely don't recommend changing the core code of the editor but you can experiment it with if you like. I'm not aware of any bug that has been fixed by that value.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy