Opened 3 years ago

Closed 3 years ago

#16410 closed Bug (duplicate)

Images loaded in text is not responsive

Reported by: michel Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. load picture in text
  2. when double clicking on picture, a windows opens
  3. fill the word "auto" in the field for 'height'
  4. on clicking on "ok" a error message appears : height must be a number.
  5. also when adding max-width: 140px; in the html-source of the text, and switching to normal view, the added parameters are gone, ...disappeared.

Expected result

These days even a pictures shown on a webpage should be ready for a responsive website by adapting itself to a smaller screen. Thus by getting smaller. For making a picture to get smaller when watching a webpage on a smaller screen, such as a tablet, an iphone... the picture should get smaller automaticaly. For obtaining this, you need to have as css parameters : width:100%; height:auto; max-width:140px; The max-width is the actual real width of the picture.

Actual result

Now it's impossible to add "max-width" because it just disappears in the code. It's not accepted. Also the height in the window-box must accept the word "auto", now it just gives a error by saying that it isn't a number.

Other details (browser, OS, CKEditor version, installed plugins)

Browser version doesn't count, it's in your ckeditor codes, it was tested on the demo page !

Attachments (1)

ckeditor.png (258.5 KB) - added by michel 3 years ago.
screenshot of an error

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by michel

Attachment: ckeditor.png added

screenshot of an error

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy