Opened 12 years ago

Closed 11 years ago

#1645 closed Bug (fixed)

Loading the samples from the filesystem doesn't work in Firefox3

Reported by: Alfonso Martínez de Lizarrondo Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.3
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed FireFox Review+ Cc:

Description

There are several errors in the console trying to load the editor from a file: uri in Firefox3 beta1

(roughly translated)

Error: uncaught exception: Permission denied to set the property Window.FCK_STATUS_NOTLOADED

Error: uncaught exception: Permission to read the property HTMLDocument.getElementById denied

...

Attachments (4)

TC_1645.png (20.0 KB) - added by Wojciech Olchawa 12 years ago.
1645_pre.patch (1.8 KB) - added by Martin Kou 11 years ago.
1645.patch (2.3 KB) - added by Martin Kou 11 years ago.
1645_2.patch (2.0 KB) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

I guess that this is due to https://bugzilla.mozilla.org/show_bug.cgi?id=230606 Probably it means that it will no longer be possible to test FCKeditor in Firefox without using a server.

comment:2 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed FF added

Also confirmed using FF beta 3

I've attached a screenshot with all the console errors. As it is an Polish bowser just one info wiersz = line.

Changed 12 years ago by Wojciech Olchawa

Attachment: TC_1645.png added

comment:3 Changed 12 years ago by Wojciech Olchawa

As it is an Polish bowser just one info wiersz = line.

Sorry what I meant was: as I use the polish version of FF3b3 one translation will be needed when viewing the attachment (wiersz = line).

comment:4 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6.2

This bug should be fixed now in 2.6.2 as Firefox3 has been released and people are starting to report strange problems that are surely this issue. http://www.fckeditor.net/forums/viewtopic.php?f=6&t=10109

I propose to detect the error and then give a message pointing to a page in the docs (or even open it directly), where the problem is explained and the about:config entry to allow the pages to work is explained.

comment:5 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:6 Changed 11 years ago by Martin Kou

Priority: NormalHigh

comment:7 Changed 11 years ago by Martin Kou

It seems there's no way to work around this in JavaScript. But the problem can be fixed by setting security.fileuri.strict_origin_policy to false in about:config.

comment:8 Changed 11 years ago by Martin Kou

I don't have the permissions to write to docs.fckeditor.net, but I've written some code to detect the situation and tell the user to disable the Firefox option.

Changed 11 years ago by Martin Kou

Attachment: 1645_pre.patch added

Changed 11 years ago by Martin Kou

Attachment: 1645.patch added

comment:9 Changed 11 years ago by Martin Kou

Keywords: Review? added

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 1645_2.patch added

comment:10 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

I've added a new patch for this with a simpler structure for the message. I've also removed the global "d" variable that was been created with the previous patch.

I'm Reviewing+ it, but you should also review it before committing.

comment:11 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2170].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy