Opened 3 years ago

Closed 3 years ago

#16469 closed Bug (invalid)

All applied formatting (e.g. Font Size/Font Name) back to default when user removes all content.

Reported by: paulam Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: paulina.masiak@…

Description

Steps to reproduce

  1. Open nightly build ​http://nightly.ckeditor.com/16-09-12-06-07/full/samples/.
  2. Change the style of whole text to: font - Georgia, size - 18 and bold.
  3. Clear all content.

Expected result

Editor should keep applied formatting changes.

Actual result

Removing content removes formatting.

Other details (browser, OS, CKEditor version, installed plugins)

Change History (2)

comment:1 Changed 3 years ago by paulam

Cc: paulina.masiak@… added

comment:2 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I can't accept this as a bug. When you apply formatting the HTML looks like below:

<p><span style="font-size:36px"><span style="font-family:Comic Sans MS,cursive"><strong>test</strong></span></span></p>

<p><span style="font-size:36px"><span style="font-family:Comic Sans MS,cursive"><strong>test</strong></span></span></p>

so when you remove contents, spans are also removed and it makes perfect sense to not keep formatting.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy