Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16587 closed Bug (duplicate)

[Safari] Failing test in plugins/font/font

Reported by: Tomasz Jakut Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.0
Keywords: Cc:

Description

The test is failing in this suite:

tests/plugins/font/font test apply font size over another font size (collapsed selection in empty span)
there is only one span in the editable
Expected: 1 (number)
Actual:   3 (number)

Safari is creating three new spans instead of one: the desired one, surrounded by two empty ones.

<p>x<em><span style="font-size:24px;"></span><span style="font-size:24px">bar</span><span style="font-size:24px;"></span></em>x</p>

Safari version: 10.0.1

Change History (10)

comment:1 Changed 3 years ago by Tomasz Jakut

Status: newconfirmed

comment:2 Changed 3 years ago by Tomasz Jakut

Milestone: CKEditor 4.6.0CKEditor 4.6.1

comment:3 Changed 3 years ago by Tomasz Jakut

Ignored in git:c0e4dc3.

comment:4 Changed 3 years ago by Marek Lewandowski

I could reproduce it starting with CKEditor 4.4.7 version, so it seems that it's a feature introduced by recent Safari updates.

comment:5 Changed 3 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:6 Changed 3 years ago by Marek Lewandowski

The problem is within insertHtml() method which is called internally by editor.insertText( 'bar' ). Basically what happens is that another span{font-size) is created for each selection boundary, so you end up with three spans.

comment:7 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.1CKEditor 4.6.2

comment:8 Changed 3 years ago by Marek Lewandowski

Owner: Marek Lewandowski deleted
Status: assignedconfirmed

Don't have the time to further investigate it.

comment:9 Changed 3 years ago by kkrzton

Resolution: duplicate
Status: confirmedclosed

This is a dup of #16588 (as the cause of this issue is the same, for more details see #16588#comment:6).

comment:10 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.2
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy