Opened 3 years ago

Closed 3 years ago

#16588 closed Bug (wontfix)

[Safari] Failing test in core/dom/element and plugins/font due to vendor issue

Reported by: Tomasz Jakut Owned by: kkrzton
Priority: Normal Milestone:
Component: General Version: 4.5.0
Keywords: CantFix VendorFix Cc:

Description

1 test in this suite is failing:

tests/core/dom/element/element test_isIdentical2
different styles formatting
Expected: true (boolean)
Actual:   false (boolean)

It seems that CKEDITOR.tools.normalizeCssText is returning different result just for Safari.

Safari version: 10.0.1

Change History (13)

comment:1 Changed 3 years ago by Tomasz Jakut

Status: newconfirmed

comment:2 Changed 3 years ago by Tomasz Jakut

Milestone: CKEditor 4.6.0CKEditor 4.6.1

comment:3 Changed 3 years ago by Tomasz Jakut

Ignored in git:c0e4dc3.

comment:4 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.1CKEditor 4.6.2

comment:5 Changed 3 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedassigned

comment:6 Changed 3 years ago by kkrzton

Based on the linked commit, four tests were ignored:

tests/core/dom/element/element.js: test_isIdentical2
tests/plugins/font/font.js: 'test apply font size over another font size (collapsed selection in empty span)'
tests/plugins/embedbase/undo.js: 'test undo and redo after creation';'test undo and redo after creation and edition'

The reason why 2 first tests are failing is visible in this codepen - http://codepen.io/f1ames/pen/mRdWbQ. Looks like a native bug, I'll report it soon. It can be workaround using

thisEl.$.setAttribute( 'style', CKEDITOR.tools.normalizeCssText( thisEl.$.style.cssText ) )

instead of

thisEl.$.style.cssText = CKEDITOR.tools.normalizeCssText( thisEl.$.style.cssText )

in https://github.com/ckeditor/ckeditor-dev/blob/master/core/dom/element.js#L942. Not sure if it is reasonable, it will be best to wait a little for a vendor answer.

The next 2 failing tests are still under investigation.

Last edited 3 years ago by kkrzton (previous) (diff)

comment:7 Changed 3 years ago by kkrzton

Status: assignedpending

Reported this issue to the Safari team (https://bugreport.apple.com/). It seems there is no direct link to the issue so I cannot post it here. The issue id is 29861252. Waiting for the vendor answer.

comment:8 Changed 3 years ago by kkrzton

Summary: [Safari] Failing test in core/dom/element/element[Safari] Failing test in core/dom/element and plugins/font due to vendor issue

comment:9 Changed 3 years ago by kkrzton

Created separate ticket for tests/plugins/embedbase/undo as the cause of failing tests is different: #16772 -> #14744.

Last edited 3 years ago by kkrzton (previous) (diff)

comment:10 Changed 3 years ago by Marek Lewandowski

You could report it directly to webkit, it's public repository, and this is the place where bug reports for safari in the end go.

comment:11 Changed 3 years ago by kkrzton

Makes sense, I will report it there too.

comment:12 Changed 3 years ago by kkrzton

Reported to WebKit bug tracker: https://bugs.webkit.org/show_bug.cgi?id=166716

comment:13 Changed 3 years ago by Marek Lewandowski

Keywords: CantFix VendorFix added
Milestone: CKEditor 4.6.2
Resolution: wontfix
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy