Opened 3 years ago

Closed 3 years ago

#16698 closed Bug (wontfix)

undo still working after resetUndo() in source mode

Reported by: Gregor Müller Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version: 4.5.11
Keywords: Cc:

Description

Steps to reproduce

  1. go to http://ckeditor.com/demo
  2. switch to source mode
  3. make some changes
  4. open console and call function resetUndo()
  5. press ctrl-z

Expected result

no undo step is being made

Actual result

editor goes back 1 step in undo history

Other details (browser, OS, CKEditor version, installed plugins)

any browser CKEditor version 4.5.11 (local version) and 4.6.0 revision 68643fd (demo site)

note: undoManager.hasUndo will be false (which is correct) after calling resetUndo() but undo will still be possible

Change History (1)

comment:1 Changed 3 years ago by Gregor Müller

Resolution: wontfix
Status: newclosed

I see this is browser behavior, since the editor is using a simple textarea, when swapping to source mode...

Too bad.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy