Opened 3 years ago

Closed 3 years ago

#16731 closed Bug (worksforme)

[iOS] Failing file tests due to "FileConstructor is not a constructor" error.

Reported by: kkrzton Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: iOS, Safari Cc:

Description

Some unit tests in:

  • tests/plugins/uploadwidget/additionalRequestParameters
  • tests/plugins/filetools/fileloader

are failing due to error:

TypeError: FileConstructor is not a constructor (evaluating 'new File( [ value ], fileName )')

Change History (3)

comment:1 Changed 3 years ago by Marek Lewandowski

Status: newconfirmed

comment:2 Changed 3 years ago by Marek Lewandowski

The fix for this is available in t/16731 branch, although it has been said that this issue might be fixed in WebKit so @k.krzton please check it.

comment:3 Changed 3 years ago by Marek Lewandowski

Resolution: worksforme
Status: confirmedclosed

I can confirm that upgrading Safari to version 10.x solves the problem.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy