Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#16733 closed Bug (fixed)

New color palette for Color Button plugin

Reported by: Wiktor Walc Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.6.2
Component: General Version:
Keywords: Cc:

Change History (7)

comment:1 Changed 20 months ago by Marek Lewandowski

Status: newconfirmed

comment:2 Changed 20 months ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedreview

comment:3 Changed 20 months ago by Marek Lewandowski

Status: reviewreview_failed

Pushed changes to branch:t/16733.

I've rebased the branch to latest master with some conflicts.

There were couple of issues which I fixed ad-hoc:

  • Added missing lang entries for new colors.
  • "More colors..." did not respect colorButton_colorsPerRow value.
  • Missing @since tag for config property.
  • Added a manual test.

There are still couple of things to be addressed though:

  • 2 colors in the palette are virtually identical.
  • We need to generate entries for translators. Btw would be nice for these new entries to contain both, english human-readable name and color hashes.

comment:4 Changed 20 months ago by Marek Lewandowski

Status: review_failedreview

I've added changes related my changes on top of the original pull request. Please review it.

Pushed to branch:t/16733.

comment:5 Changed 20 months ago by kkrzton

Status: reviewreview_passed

Looks good!

comment:6 Changed 20 months ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

Fixed with git:43c4194.

comment:7 Changed 20 months ago by Marek Lewandowski

Summary: Colorbutton plugin improvementsNew color palette for Color Button plugin
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy