Opened 3 years ago

Closed 3 years ago

#16748 closed Bug (invalid)

Duplicate html tags are generated when a user toggles between the Source and WYSIWYG view in CKEditor

Reported by: Michel Deblois Owned by:
Priority: Normal Milestone:
Component: General Version: 4.6.1
Keywords: keeptextselection Cc:

Description

Both table and list (ul, ol, li) tags are duplicated. For example, an empty list item (li) will get generated when switching from Source to WYSIWYG view, if the user's cursor is somewhere in the html list when switching to WYSIWYG view.

Steps to reproduce

  1. Add bullet list with two items
  2. Switch editor to "Source" view
  3. Put cursor after <ul> tag
  4. Switch back to "WYSIWYG" view

Expected result

Cursor should remain at the same location in the text

Actual result

Duplicate <li> item is generated

Other details (browser, OS, CKEditor version, installed plugins)

Chrome OS CKEditor 4.6.1 (full package) KeepTextSelection plugin

Change History (1)

comment:1 Changed 3 years ago by Tade0

Resolution: invalid
Status: newclosed

Could not reproduce without the KeepTextSelection plugin(which is a 3rd party plugin), so I assume it's causing the mentioned problem.

I think your best course of action now is to file an issue in the plugin's repo: https://github.com/w8tcha/CKEditor-TextSelection-Plugin/issues

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy