Opened 3 years ago

Closed 3 years ago

#16749 closed Bug (invalid)

CK Editor deletes code it does not understand

Reported by: Philip_1995 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Switch code edit mode
  2. Type some html that you can not generate with ckeditor e.g html 5 video player
  3. switch back/submit form

Expected result

A page with a video clip

Actual result

a p tag with the message that would showing the message if browser does not support the html 5 player

Other details (browser, OS, CKEditor version, installed plugins)

This is not limited to new html 5 tags anything that ck editor does not understand will get removed/changed e.g. bootstrap classes

Change History (1)

comment:1 Changed 3 years ago by Tade0

Resolution: invalid
Status: newclosed

This is by design and done by the Advanced Content Filter: http://docs.ckeditor.com/#!/guide/dev_acf

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy