Opened 3 years ago

Closed 3 years ago

#16787 closed Bug (worksforme)

[Edge] Undo-redo flicker when style applied

Reported by: Tade0 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Build latest master.
  2. Open the /samples page and apply the "Special Container" style to the content.
  3. Hit Undo twice

Expected result

After first undo nothing interesting should happen.

Actual result

On second undo the style appears for a split second only to disappear.

Other details (browser, OS, CKEditor version, installed plugins)

Edge 14.14393

Change History (4)

comment:1 Changed 3 years ago by Marek Lewandowski

Can't reproduce it. Is there any particular block, where the style should be applied? Should undo be hit with keyboard or a UI button and a mouse?

comment:2 Changed 3 years ago by Marek Lewandowski

Resolution: worksforme
Status: newclosed

@t.jakut can't reproduce it either.

comment:3 Changed 3 years ago by Tade0

Resolution: worksforme
Status: closedreopened

Different procedure:

  1. Apply the "Special container" style to "hello world"
  2. Undo.
  3. Apply the style again.
  4. Undo.
  5. Redo.
  6. Try to undo.

comment:4 Changed 3 years ago by Jakub Ś

Resolution: worksforme
Status: reopenedclosed

I could not reproduce it as well with any of given test cases.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy