Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16802 closed Bug (duplicate)

ForceSimpleAmpersand is ignored

Reported by: Oliver Jusinger Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. CKEDITOR.config.forceSimpleAmpersand = true;
  2. save an link with href=http://www.foo.bar/?foo=bar&foo=bar
  3. forceSimpleAmpersand is ignored

Expected result

href=http://www.foo.bar/?foo=bar&foo=bar

Actual result

http://www.foo.bar/?foo=bar&foo=bar

Other details (browser, OS, CKEditor version, installed plugins)

4.7.1 and earlier

Fix: htmlwriter/plugin.js move htmlEncodeAttr before forceSimpleAmpersand handling:

Diff:

181a182
> 				attValue = CKEDITOR.tools.htmlEncodeAttr( attValue );
184d184
< 				attValue = CKEDITOR.tools.htmlEncodeAttr( attValue );

(limited js and ckeditor knowledge, but the fix works for me)

Change History (3)

comment:1 Changed 3 years ago by Oliver Jusinger

Summary: Fix for forceSimpleAmpersandForceSimpleAmpersand is ignored

comment:2 Changed 3 years ago by Jakub Ś

Keywords: forceSimpleAmpersand removed
Resolution: duplicate
Status: newclosed
Version: 4.7.0 (GitHub - major)

DUP of #13723.

Last edited 3 years ago by Jakub Ś (previous) (diff)

comment:3 in reply to:  2 Changed 3 years ago by Oliver Jusinger

Replying to j.swiderski:

DUP of #13732.

#13723

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy