Opened 3 years ago

Closed 3 years ago

#16803 closed Bug (worksforme)

[MAC] Certain CK Editor Keyboard shorcuts does not work on MAC

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: Irina

Description

Steps to reproduce

  1. Open nightly build http://nightly.ckeditor.com/17-01-17-07-06/full/samples/in Safari or any browser on MAC
  2. Try to use Keyboard shortcuts defined in Accessibility Instructions dialog

Issue: Below keyboard shortcuts does not work on MAC in an Browser

Editor Toolbar

Press Alt+F10 to navigate to the toolbar. Move to the next and previous toolbar group with TAB and SHIFT+TAB. Move to the next and previous toolbar button with RIGHT ARROW or LEFT ARROW. Press SPACE or ENTER to activate the toolbar button.

Editor Context Menu

Press Shift+Ctrl+F10 or APPLICATION KEY to open context-menu.

Editor Element Path Bar

Press Alt+F11 to navigate to the elements path bar. Move to next element button with TAB or RIGHT ARROW. Move to previous button with SHIFT+TAB or LEFT ARROW. Press SPACE or ENTER to select the element in editor.

Change History (7)

comment:1 Changed 3 years ago by Jakub Ś

Cc: Irina added; IBM removed
Keywords: IBM added; irina removed
Status: newpending
Version: 4.7.0 (GitHub - major)

I have just tried all the keys mentioned in and all were working as expected. I have tried CKEditor 4.6.2 and the latest nightly.

Can anyone else reproduce this?

comment:2 Changed 3 years ago by Tomasz Jakut

Probably I know why the issue is present.

By default pressing F10 on mac behaves like Fn+F10 (so pressing F10 mutes the speakers). In that case the real keyboard shortcut for accessing menu is Fn+Alt+F10.

That keyboard setting could be altered by enabling "Use F1, F2, etc. keys as standard function keys" in "System Preferences"→"Keyboard".

comment:3 in reply to:  1 Changed 3 years ago by Satya Minnekanti

Replying to j.swiderski:

I have just tried all the keys mentioned in and all were working as expected. I have tried CKEditor 4.6.2 and the latest nightly.

Can anyone else reproduce this?

@j.swiderski as mentioned in Defect Summary this happens on a MAC NOT WINDOWS. Please try those Keyboard shortcuts on MAC

comment:4 Changed 3 years ago by Jakub Ś

@j.swiderski as mentioned in Defect Summary this happens on a MAC NOT WINDOWS. Please try those Keyboard shortcuts on MAC

I have used Mac but the problem is I have used it on a Virtual Machine with Windows as a Host. Looking at what @t.jakut has written it makes sense why it has worked for me.

Then again when looking at MAC keyboard its very intuitive IMO that Fn needs to be pressed in order to "enable" F10.

Last edited 3 years ago by Jakub Ś (previous) (diff)

comment:5 Changed 3 years ago by Marek Lewandowski

Correct it's possible that it's simply due to function lock being enabled on macs by default, @satya could you check it?

comment:6 in reply to:  5 Changed 3 years ago by Satya Minnekanti

Replying to m.lewandowski:

Correct it's possible that it's simply due to function lock being enabled on macs by default, @satya could you check it?

@j.swiderski @t.jakut Thanks for explanatiopn. That change worked. you can close the ticket

comment:7 Changed 3 years ago by Jakub Ś

Resolution: worksforme
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy