Opened 3 years ago

Last modified 3 years ago

#16886 confirmed Bug

Toolbar configurator won't work with A11y Checker

Reported by: miramar Owned by:
Priority: Normal Milestone:
Component: Toolbar Configurator Version: 4.3
Keywords: Cc:

Description

Steps to reproduce

  1. http://ckeditor.com/builder/01de32482a9e0b7b308c0203377d5594 OR http://ckeditor.com/builder/download/01de32482a9e0b7b308c0203377d5594
  2. Run toolbar configurator

Expected result

Toolbar configurator to load and allow customization.

Actual result

Errors out.

Uncaught TypeError: Cannot set property 'innerText' of null ckeditor.js:1563

Also get Uncaught TypeError: Cannot read property 'refresh' of null index.html:200 when switching from basic to advanced or vice versa.

Other details (browser, OS, CKEditor version, installed plugins)

Tried Chrome and Firefox, CKEditor 4.6.1 and also just tried 4.6.2. Have a few plugins extra that can be seen in the builder. I also tried adding jquery into the page but still get errors.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Status: newconfirmed
Summary: Toolbar configurator won't loadToolbar configurator won't work with A11y Checker
Version: 4.6.24.3

I have checked your build with and without custom plugins but in source mode

When are using all the plugin, there are two errors reported:

  1. TypeError: counterElement(...) is null for wordcount plugin. This isn't our plugin thus we will not be able to fix it - please report this issue to plugin author.
  2. Error: Missing jQuery. Accessibility Checker's default engine, Quail.js requires jQuery to work correctly. - this error is reported for A11y Checker. This plugin has been created by CKSource and this part of the bug report is valid.
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy