Opened 10 years ago

Closed 10 years ago

#1691 closed Bug (fixed)

Safari: new links do not appear in editor unless text is made into a link

Reported by: designfu Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: Safari Compatibility
Component: UI : Dialogs Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Safari Review+ Cc:

Description (last modified by Martin Kou)

Reproduce:

  • Visit any FCKeditor release, including nightly as of 12/20/07.
  • Do not select any text in the editor. (Does work when you select text)
  • Click Link button.
  • Enter any information.
  • Click OK.

Problem: Link does not appear.

System: Mac OS X/Intel, unmodified Safari 3.0.2.

Attachments (3)

1691.patch (1.1 KB) - added by Alfonso Martínez de Lizarrondo 10 years ago.
Proposed SVN patch
1691_2.patch (1.8 KB) - added by Frederico Caldeira Knabben 10 years ago.
1691_3.patch (1.8 KB) - added by Frederico Caldeira Knabben 10 years ago.
Fixed a typo in the comments

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added

Confirmed in Safari 3.0.4 (523.15) using 2.5.1 and 2.5 SVN Build 18195 versions

comment:2 Changed 10 years ago by Wojciech Olchawa

Keywords: Safari added
Summary: Safari 3: new links do not appear in editor unless text is made into a linkSafari: new links do not appear in editor unless text is made into a link

comment:3 Changed 10 years ago by Martin Kou

Description: modified (diff)

Tidied up the description.

comment:4 Changed 10 years ago by Paul Wilton

Confirmed in Safari 3.1 also Any chance this bug can be fixed soon - or reclassified as High Priority? it seems like core functionality to me.

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

This is a regression of [1096]

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

Changed 10 years ago by Alfonso Martínez de Lizarrondo

Attachment: 1691.patch added

Proposed SVN patch

comment:7 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Alfonso Martínez de Lizarrondo to Frederico Caldeira Knabben
Status: assignednew

I can't understand the (url != '#' ? url : '') in the patch... when is url supposed to be '#'?

Also, the real problem is that, only for Safari, FCK.CreateLink will create and return a link for a collapsed selection. All other browsers will not create that link. A side effect of it is that the link results for collapsed selections will be different on Safari. In that browser, anchors will have the "#", and e-mails will show the "mailto:" and search part of the link.

So, the correct solution would be making FCK.CreateLink behave in the same way for all browsers. I'll be attaching another patch proposal to try to achieve it.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 1691_2.patch added

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 1691_3.patch added

Fixed a typo in the comments

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review- removed
Status: newassigned

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review+ removed

Damned! I've used the wrong keyword... again... and again. Correcting it.

comment:11 in reply to:  8 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

Replying to fredck:

I can't understand the (url != '#' ? url : '') in the patch... when is url supposed to be '#'?

From the anchor dialog, this function was called with url = '#', and this way it seemed to be an easy workaround (not a real solutio)

Also, the real problem is that, only for Safari, FCK.CreateLink will create and return a link for a collapsed selection. All other browsers will not create that link. A side effect of it is that the link results for collapsed selections will be different on Safari. In that browser, anchors will have the "#", and e-mails will show the "mailto:" and search part of the link.

Yes, I noticed it, and I tried to leave the browser create the link in that situation, although I wasn't really proud of the solution.

This one on the other side looks like it will solve all the problems as all the browsers (even future ones) will have the same behavior.

comment:12 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1997]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy