#16915 closed Bug (invalid)

Nested Bullets/Numbering doesn't work properly in CKEditor in IE11

Reported by: Pawan Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Open the attached word document.
  2. Copy entire text.
  3. Paste it to CKEditor in IE11.

Expected result

It should be copied as displayed in the word file.

Actual result

Unwanted bullets, Line space and characters appear.

Other details (browser, OS, CKEditor version, installed plugins) == Browser-IE11, CKEditor- 4.6.1 with latest version of PasteFromWord and Clipboard

Attached docs: 1) word docuement from text should be copied. 2) image file, what it gets copied in CKEditor.

Attachments (3)

TestDocWithNestedBullets.docx (15.8 KB) - added by Pawan 21 months ago.
File that has text that should be copied to CKEditor
CopiedToCkeditorInIE11.png (39.4 KB) - added by Pawan 21 months ago.
What it paste in CKEditor in IE11
TestDocWithNestedBullets1.docx (15.5 KB) - added by Jakub Ś 21 months ago.

Download all attachments as: .zip

Change History (4)

Changed 21 months ago by Pawan

File that has text that should be copied to CKEditor

Changed 21 months ago by Pawan

Attachment: CopiedToCkeditorInIE11.png added

What it paste in CKEditor in IE11

comment:1 Changed 21 months ago by Jakub Ś

Keywords: PasteFromWord removed
Resolution: invalid
Status: newclosed
Version: 4.7.0 (GitHub - major)

It should be copied as displayed in the word file.

No it should not because list is created incorrectly.

The a) Earthquake – As respects all locations: is a list then there is a paragraph and new list (not a sublist) • Property Damage – 5% of the then there are two empty paragraphs and another paragraph The above Earthquake deductibles are which isn't part of • Property Damage – 5% of the . All this can be checked in Word document by inspecting what which element is.

If the list was created with List elements and Shift+Enter like in the attached document, it would be displayed correctly.

Changed 21 months ago by Jakub Ś

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy