Opened 3 years ago

Closed 3 years ago

#17001 closed Bug (fixed)

Object element inserted on paste

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.7.0
Component: General Version: 4.7.0
Keywords: Cc:

Description

Steps to reproduce

  1. Open attached file in MS Word.
  2. Select all, copy to clipboard.
  3. Open a CKEditor sample that includes flash plugin (so that the issue is more visible).
  4. Paste into the editor using CTRL/CMD + V.

Expected result

No object elements are created.

Actual result

An object elements is created.

Other details (browser, OS, CKEditor version, installed plugins)

Firefox, Chrome.

It's due to object element in datatransfer.

Attachments (1)

text with different fonts supported in CK Editor.docx (11.3 KB) - added by Marek Lewandowski 3 years ago.

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by Marek Lewandowski

comment:1 Changed 3 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: newreview

comment:2 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.7.0
Resolution: fixed
Status: reviewclosed

Merged with git:77664e89f.

It doesn't deserve a separate changelog entry, as it hadn't been yet published.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy