Opened 2 years ago

Closed 21 months ago

#17004 closed Bug (wontfix)

Post Editor - Useragent sniffing breaks it in Pale Moon

Reported by: Arthmoor Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description

I was directed to report this here by Rhett Buck at Invision Power Services (no, I'm not happy about being passed off when you're not the guys I'm paying for support). There is an issue with the CKEditor supplied to them, and on your own homepage as well. I am using the Pale Moon web browser, originally a fork from Firefox, but diverging into its own entity more recently. When attempting to use any function of IPB where the editor is needed, all that happens is the text box stalls with "Loading..." and never comes up. I have confirmed this across at least 5 sites now using IPB 4 where I have accounts and can post. There is also confirmation in other packages such as Drupal that the editor will do the same thing there. I have also verified that your own samples on the front page at ckeditor.com cause the red throbber to spin forever and nothing loads. I have traced this down to a useragent issue.

Pale Moon defaults to this useragent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:3.2) Goanna/20170422 PaleMoon/27.3.0

If I change it to this: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0 PaleMoon/27.3.0 then everything works properly, including the demos on your front homepage.

Rhett then found another post on the Pale Moon forums where a user tracked it down even further to your ckeditor.js parsing the useragent incorrectly based on the rv: parameter. The link to that post is here: https://forum.palemoon.org/viewtopic.php?t=13035

Since Pale Moon is a legitimate desktop web browser used by millions of people, I think this is an issue that should be addressed in your detection scheme so that it benefits anyone using your package downstream, like IPB and Drupal, and users on sites with that software don't have to spoof a useragent to get access to something that clearly works just fine. This seems like a relatively simple fix that will maintain the intent of your compatibility check without locking out those of us who are by choice using something that's not Firefox, IE, or Chrome.

Change History (3)

comment:1 Changed 2 years ago by Jakub Ś

Keywords: useragent browser removed
Status: newconfirmed
Version: 4.7.0 (GitHub - major)4.0

We don't support this browser however I think it makes sense to add this sniff as well.

I'm not sure however if all the features will work as expected. Maybe if we set this browser as Gecko?

@Arthmoor if you have active support token, you could have reported this issue through our contact form.

comment:2 Changed 2 years ago by Arthmoor

I'm not sure what "active support token" means. I was referred here by the people at IPB support, who I really think should have handled this, but hey.

In any case, all of the features work as expected if either the useragent is changed or that javascript is changed. Pale Moon isn't technically using Gecko anymore but it renders according to HTML standards.

I'd really rather not have to spoof the useragent since it's deceptive to traffic logs and paints an inaccurate picture of what people are actually using.

comment:3 Changed 21 months ago by Mateusz Samsel

Resolution: wontfix
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy