Opened 7 months ago

Closed 5 months ago

#17003 closed Bug (fixed)

Chrome Version 58.0.3029.81 Crashes WIth Form Inputs

Reported by: esmithud Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Chrome Cc:

Description

Steps to reproduce

  1. Go to http://nightly.ckeditor.com/17-05-02-06-09/full/samples/
  2. Add text field, check box, radio, or other form element. (example: <input type="text" />).
  3. Click on source button to view source.
  4. Click on source button again to re-render frame.
  5. Click around the text input field or other form element and chrome will freeze/crash. A window prompting the user to kill the page will sometimes appear. Other times the tab or window or entire chrome process needs to be killed.

Firefox (53.0) seems to not have this issue and works normally.

Expected result

Able to continue editing.

Actual result

Freeze/crash of Chrome.

Other details (browser, OS, CKEditor version, installed plugins)

Latest/nightly build: http://nightly.ckeditor.com/17-05-02-06-09/full/samples/ ==

Change History (4)

comment:1 Changed 7 months ago by alonhb

Hi, We are experiencing similar issue as well. It seems to be a problem of the "contenteditable='false'" attribute on input fields inside ckeditor container. This issue is related to how ckeditor is implementing input fields inside ckeditor, but it looks like a chrome bug. Here is a plnkr demonstrating the issue, WITHOUT ckeditor: https://embed.plnkr.co/Cj1xr3j47tUO3v6ugTZd/

comment:2 Changed 6 months ago by Jakub Ś

Keywords: Crash Freeze Form Form Elements removed
Status: newconfirmed
Version: 4.7.0 (GitHub - major)4.0

#17039 was marked as duplicate. There is a TC for textarea in that ticket.

comment:3 Changed 6 months ago by Jakub Ś

#17061 was marked as duplicate.

comment:4 Changed 5 months ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

It seems this issue in now fixed in Chrome 59. I have checked all the test cases and everything works as expected.

Please upgrade your Chrome to version 59.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy