Opened 12 years ago

Closed 6 years ago

#1729 closed New Feature (duplicate)

Allowing user to click on link in editable area without holding CTRL button.

Reported by: Arun kumar Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: Discussion Cc:

Description

User must be able to click on the link in editor area without holding CTRL button to open the linked page. Normally, in the current scenario, if user creates a link in FCKEditor, then to open that link, the user has to click on that link by holding CTRL key. What I'm asking is that user must be able to open that link page directly by clicking on it without holding CTRL key.

Thank you.

Change History (6)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Discussion added

This feature would bring a big usability issue. If you have a typo in the linked text, you would certainly click on it to fix that typo. It would unexpectedly open the link instead, and the only way to fix the text would be by using the keyboard arrows to move to the correction point.

I vote to not include this feature in the core. A third party plugin could be created for it instead.

comment:2 Changed 12 years ago by Martin Kou

I concur with Fred's argument, editing the text contents of a link by clicking the link in the editing area is a very common use case, and it is what most user expects from their previous experience in other rich text editing or word processing software. Opening a link by clicking in the editing area would surprise most users, therefore violating the least surprise rule.

comment:3 Changed 12 years ago by Arun kumar

Then we should have at least an option to enable this. Which is not available by default.

comment:4 Changed 12 years ago by Alfonso Martínez de Lizarrondo

I also agree that that a plugin is the better option. I don't think that even 1% of the people would want this feature enabled because it will made really hard editing of links or images included in links.

By the way, the Ctrl+Click option only works in Firefox.

comment:5 in reply to:  4 Changed 11 years ago by Arun kumar

How to enable onClick to a link?

I need to do it urgently.

comment:6 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

I'm closing this issue as duplicate of #7145.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy