Opened 10 years ago

Closed 10 years ago

#1728 closed Bug (fixed)

Opera: external toolbar is too small

Reported by: Martin Kou Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Review+ Cc:

Description

This bug was discovered while I was working on #1514.

Reproduction procedure:

  1. Open sample11.html in Opera 9.50 build 9721 or later.
  2. Notice the toolbar only contains two visible rows, while it contains three in other browsers.

This ticket is expected to be fixed with #1514 as both the floating panel code and toolbar code is being reviewed and modified for the ticket.

Attachments (2)

1728.patch (1.8 KB) - added by Martin Kou 10 years ago.
Proposed patch for fixing #1728.
1728_2.patch (2.4 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Martin Kou

A patch has been written for #1514 but it doesn't fix this bug yet, because #1514's patch is already fixing a bunch of issues. Another separate patch will be written for this bug instead.

Changed 10 years ago by Martin Kou

Attachment: 1728.patch added

Proposed patch for fixing #1728.

comment:2 Changed 10 years ago by Martin Kou

Keywords: Review? added; Confirmed Opera removed

comment:3 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

Maybe it could be better to also make the window.onresize event work with the poller function, so if this kind of problem can happen also in that situation it's automatically protected.

Changed 10 years ago by Martin Kou

Attachment: 1728_2.patch added

comment:4 Changed 10 years ago by Martin Kou

Keywords: Review? added; Review- removed

I've updated the patch so that both onload and onresize would use the same poller function to detect the correct size of the toolbar.

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [1466].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy