Ticket #1774 (closed Bug: worksforme)

Opened 6 years ago

Last modified 3 years ago

IE: <LI> without <OL> consumes sibling nodes

Reported by: Scott Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: SVN (FCKeditor) - Retired
Keywords: IE Cc:

Description

Setting the source to:

<li>Item</li>
<li>Item 2</li>
<p>paragraph</p>

Changes it to:

<p>
<li>Item</li>
<li>Item 2
<p>paragraph</p>

</li> </p>

There are two things that are happening here. FixBody() is wrapping everything in a <P> tag. This is not the bug.

Somewhere else, the last <li> tag is being opened up to allow everything else to be nested underneath it.

I realise that there really shouldnt be any <li>s without <ol> or <ul> but sometimes bad code can be pasted in which contain things like this.

Change History

comment:1 Changed 6 years ago by Scott

Edit: Changes it to:

<p>
<li>Item</li>
<li>Item 2
<p>paragraph</p>
</li> </p> 

comment:2 Changed 6 years ago by w.olchawa

Confirmed with IE and IE7. Works fine with FF2, where the result is :

<p>
<li>Item</li>
<li>Item 2</li>
</p>
<p>paragraph</p>

comment:3 Changed 6 years ago by w.olchawa

  • Keywords Confirmed IE IE7 added

comment:4 Changed 6 years ago by w.olchawa

  • Keywords IE7 removed

comment:5 Changed 6 years ago by alfonsoml

  • Component changed from UI : Source View to Core : Output Data

comment:6 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

WFM in CKE3.6.2Trunk, result is:

<ul>
	<li>
		Item</li>
	<li>
		Item 2</li>
</ul>
<p>
	paragraph</p>

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy