Opened 12 years ago

Closed 12 years ago

#1775 closed Bug (worksforme)

Find / Replace on empty text changes the text

Reported by: smozely Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: WorkForMe Pending Cc:

Description

Happens on IE :- 6.0.2800.1106CO, doesn't happen in FireFox 2.0.0.11
Happened with 2.5.1 and with the nightly from 01/21/2008

If the text in the editor is empty doing a find or a find/replace changes the source from being empty to something like

--- Start
<p></p>
<p>&nbsp;</p>
--- End

and between what looks like the empty p tag is a character that doesn't get displayed in the editor (but it gets passed back to my webserver, in my java server comes back as char code -1)

But thinking that the bug is that a search on blank text shouldn't be modifying the text.

Change History (2)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: WorkForMe Pending added
Version: FCKeditor 2.5.1

Hi. I was trying to reproduce your bug in IE but I wasn't successful. The editor behaves normally for me. Could you please write what are your specific actions when I use the find/replace function? Does the problem occur only when the dialog box is opened and closed or do you have to run the find/replace function?

comment:2 Changed 12 years ago by Wojciech Olchawa

Resolution: worksforme
Status: newclosed

Ticket expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy