Opened 11 years ago

Closed 11 years ago

#1780 closed Bug (fixed)

Formatting removes space after a word (Mediawiki/WYSIWYG).

Reported by: Robbie62 Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Confirmed Cc:

Description

I have a website hosted by wiki-site.com. You can reproduce this problem by going to www.wiki-site.com and using their sandbox. I could find out what version of fckeditor they are using but I know they are using mediawiki 1.11.

In the WYSIWYG view, if I select several words for formatting such that I also select the space after the last word, when I apply formatting and save it (or just switch to wikitext and back), the space after that last word is removed. And in WYSIWYG view, it you add that space back in, it will delete it again when you save it.

Ex. This is an example of a line of text. (I then select "example of a line " (by default the selection wants to include that space after "line"). I then click bold. Then if I switch to wikitext and back, I get: This is an example of a lineof text.

A few times, I have also encountered the problem of getting 6 or 9 apostrophes in a row when editing bold formatted text. I have been unable however to reproduce it.

I have also had the problems of added lines in bulleted/numbered lists like the comments on the main page.

I was looking forward to getting others to start using the Wiki with WYSIWYG but it's too buggy right now.

Thanks for your help.

Change History (4)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Formatting spaces removed
Priority: HighNormal

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

You are right. I reviewed your problem and it exists. We will try to work on the problem. For now my suggestion is that you may mark words (sentences) without the space after the last word or try to work the bold text inside the wikitext: '''some text'''. I know it isn't a outrageous solution but unfortunately for now it is the only one.

comment:3 Changed 11 years ago by Julia

I'm interested too. (If this bug really corresponds to my problem, I will give details too as soon as possible)!

comment:4 Changed 11 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [1837]. See also bug #1015 regarding "6 or 9 apostrophes" issue.

Please test it if possible, because I'm not sure whether this fix is 100% correct.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy