Opened 11 years ago

Closed 8 years ago

#1793 closed Bug (worksforme)

Paste as plain text does not work properly in IE

Reported by: naveinf Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: IE Cc:

Description (last modified by Krzysztof Studnik)

  1. Open the editor
  2. Press enter twice so you have 3 lines in the editor.
  3. Go to the second line. Type the text “Sample Text”.
  4. Make the text bold and change the color.
  5. Copy the text using the icon on the tool bar.
  6. Place the cursor on the 3rd line. Click on the “Paste as plain text” icon.

Expected Behaviour: The text should have been pasted on the third line without any formatting.

Actual Behaviour: The text gets pasted on the second line after the copied text with the original formatting applied.

Found using the following

Browser: IE 6.0.2900

OS : Windows XP Prof

Change History (5)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Version: FCKeditor 2.5.1

Confirmed with IE. Works with IE7 and FF2

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.7

comment:3 Changed 11 years ago by Julia

I'm interested too. (If this bug really corresponds to my problem, I will give details too as soon as possible)!

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Component: Core : StylesGeneral

comment:5 Changed 8 years ago by Krzysztof Studnik

Description: modified (diff)
Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy