Opened 10 years ago

Closed 9 years ago

#1792 closed Bug (fixed)

[IE] Infinity loop problem in multiple editor

Reported by: Yang Gyu Lee Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Review+ Cc: Mark Buckallew

Description

Thank for FCKeditor team.
I using your product very usefully.
But I found a bug.
Please patch this bug... thank you

If change editor focus by mouse clicking then Internet Explorer fall into infinity loop in multiple editor page.
I create three editors in a page.
Click a first editor to edit html and switch to other window and click second editor then the editor fall into infinity loop.

The bug has in your sample page.
http://www.fckeditor.net/nightly/fckeditor/_samples/default.html[[BR]]

Change sample to FCKeditor - JavaScript - Sample 9 : Complex form(multiple editors)
Then two editors will be shown.
I will call EditorA (FCKeditor with Basic toolbar) and EditorB (FCKeditor with Default toolbar)

Steps to reproduce:

  1. Click EditorA
  2. Click the other window (except the fckeidtor browser)
  3. Click EditorB
  4. Then the Internet Explorer will be falled into infinity loop.


Browser name and OS
Internet Explorer 6 and 7
Windows XP sp2


Screenshot
No screenshot because bug is not editor content problem but infinity loop.

Sample data
Not need sample data...
This bug occur with any data..
I think that this bug is not related with a data...

Thank you.

Attachments (1)

1792.patch (2.9 KB) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added
Version: SVN

Hi!

I've tried to reproduce your bug but I was unsuccessful. Everything seems to work for me both in IE and IE7. So could you let me know what did you mean by 2. Click the other window (except the fckeidtor browser) because I interpreted it as clicking somewhere outside the editor, however I could misunderstood you.

Thanks!

comment:2 Changed 9 years ago by Alex Bakhar

Hi! I have the same bug reproduced with IE6 (6.0.2900.2180.xpsp_sp2_gdr.070227-2254) at WindowsXP SP2.
Steps to reproduce:

  1. Run IE browser to open sample page with multiple editors as shown in the previous post.
  2. Click first editor area to make it to get focus.
  3. Click Start menu.
  4. Click second editor area.

IE becomes unresponding. I think the bug caused by focus/blur routines.

comment:3 Changed 9 years ago by Wojciech Olchawa

Keywords: Confirmed IE added; Pending WorksForMe removed
Summary: Infinity loop problem in multiple editor[IE] Infinity loop problem in multiple editor

Confirmed using latest SVN version bot on IE6 and IE7.

comment:4 Changed 9 years ago by Wojciech Olchawa

#1988 has been marked as DUP

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Cc: Mark Buckallew added

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 1792.patch added

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Milestone: FCKeditor 2.6
Owner: set to Frederico Caldeira Knabben
Status: newassigned

This is a regression for a bug I've worked on in the far 2006. As abakhar well understood, it is caused by the focus procedures, combined with the FCKFocusManager.

The problem is that the FCKFocusManager tries to enforce the focus to the editing area as soon as the editor window receives the focus. The code to do that fires the focus event again, and so FCKFocusManager starts the same procedure... in an infinite loop.

Our previous approach was blocking this issue in the focus procedure. But it seems that a safer solution is avoiding the loop at the FCKFocusManager code.

The attached patch, other than proposing the above approach, changes the FCKEditingArea.Focus code to make it clearer, canceling also a bug present on it currently, by a "return" statement wrong removed from line 275 with [620].

comment:7 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

My tests seems to work fine

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1775]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy